]> git.pld-linux.org Git - packages/perl-prefork.git/blob - perl-prefork.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-prefork.git] / perl-prefork.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    prefork
6 Summary:        prefork - optimize module loading across forking and non-forking scenarios
7 Summary(pl.UTF-8):      prefork - optymalizacja ładowania modułów dla rozwidlonych i nierozwidlonych scenariuszy
8 Name:           perl-prefork
9 Version:        1.04
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/A/AD/ADAMK/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  47a514d4058ffc8cca184b28d6d54d0a
16 URL:            http://search.cpan.org/dist/prefork/
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.24-2
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The prefork pragma is intended to allow module writers to optimise
25 module loading for both scenarios with as little additional code as
26 possible.
27
28 The prefork.pm is intended to serve as a central and optional
29 marshalling point for state detection (are we running in procedural or
30 pre-forking mode) and to act as a relatively light-weight module
31 loader.
32
33 %description -l pl.UTF-8
34 prefork ma umożliwić piszącym moduły zoptymalizowanie ładowania
35 modułów dla obu scenariuszy przy użyciu jak najmniejszego dodatkowego
36 kodu.
37
38 prefork.pm ma służyć jako centralny i opcjonalnie prowadzący punkt dla
39 wykrywania stanów (czy program działa w trybie proceduralnym, czy
40 pre-fork) i działać jako relatywnie lekki moduł do wczytywania
41 modułów.
42
43 %prep
44 %setup -q -n %{pdir}-%{version}
45
46 %build
47 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"%{pdir}")' \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
60 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/prefork/.packlist
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes
68 %{perl_vendorlib}/*.pm
69 %{_mandir}/man3/*
This page took 0.066039 seconds and 3 git commands to generate.