]> git.pld-linux.org Git - packages/perl-prefork.git/blob - perl-prefork.spec
519ffceec9fd65a9d1547be1253f9b2ef955837f
[packages/perl-prefork.git] / perl-prefork.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    prefork
7 Summary:        prefork - optimize module loading across forking and non-forking scenarios
8 Summary(pl.UTF-8):      prefork - optymalizacja ładowania modułów dla rozwidlonych i nierozwidlonych scenariuszy
9 Name:           perl-prefork
10 Version:        1.04
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/A/AD/ADAMK/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  47a514d4058ffc8cca184b28d6d54d0a
17 URL:            http://search.cpan.org/dist/prefork/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.24-2
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The prefork pragma is intended to allow module writers to optimise
26 module loading for both scenarios with as little additional code as
27 possible.
28
29 The prefork.pm is intended to serve as a central and optional
30 marshalling point for state detection (are we running in procedural or
31 pre-forking mode) and to act as a relatively light-weight module
32 loader.
33
34 %description -l pl.UTF-8
35 prefork ma umożliwić piszącym moduły zoptymalizowanie ładowania
36 modułów dla obu scenariuszy przy użyciu jak najmniejszego dodatkowego
37 kodu.
38
39 prefork.pm ma służyć jako centralny i opcjonalnie prowadzący punkt dla
40 wykrywania stanów (czy program działa w trybie proceduralnym, czy
41 pre-fork) i działać jako relatywnie lekki moduł do wczytywania
42 modułów.
43
44 %prep
45 %setup -q -n %{pdir}-%{version}
46
47 %build
48 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"%{pdir}")' \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
61 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/prefork/.packlist
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes
69 %{perl_vendorlib}/*.pm
70 %{_mandir}/man3/*
This page took 0.074747 seconds and 2 git commands to generate.