]> git.pld-linux.org Git - packages/perl-namespace-autoclean.git/blob - perl-namespace-autoclean.spec
8a8e6af7c23ee6985f1a6a013091c227cffc75f6
[packages/perl-namespace-autoclean.git] / perl-namespace-autoclean.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    namespace
6 %define pnam    autoclean
7 Summary:        namespace::autoclean removes all imported symbols at the end of compile cycle
8 Summary(pl.UTF-8):      namespace::autoclean usuwa wszystkie zaimportowane symbole pod koniec cyklu kompilacji
9 Name:           perl-namespace-autoclean
10 Version:        0.29
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/namespace/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  39b38c776cd1f0ee03cc70781a2f2798
16 URL:            http://search.cpan.org/dist/namespace-autoclean/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-B-Hooks-EndOfScope >= 0.12
21 BuildRequires:  perl-Sub-Identify
22 BuildRequires:  perl-Test-Requires
23 BuildRequires:  perl-Test-Simple >= 0.88
24 BuildRequires:  perl-namespace-clean >= 0.20
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 When you import a function into a Perl package, it will naturally also
31 be available as a method.
32
33 The namespace::autoclean pragma will remove all imported symbols at
34 the end of the current package's compile cycle. Functions called in
35 the package itself will still be bound by their name, but they won't
36 show up as methods on your class or instances.
37
38 This module is very similar to namespace::clean, except it will clean
39 all imported functions, no matter if you imported them before or after
40 you used the pagma. It will also not touch anything that looks like a
41 method, according to Class::MOP::Class::get_method_list.
42
43 %description -l pl.UTF-8
44 namespace::autoclean usuwa wszystkie zaimportowane symbole pod koniec
45 cyklu kompilacji
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/namespace/*.pm
70 %{_mandir}/man3/*
This page took 0.116632 seconds and 2 git commands to generate.