]> git.pld-linux.org Git - packages/perl-libnet.git/blob - perl-libnet.spec
39b1ff7efcb0c43b9f5f69d4affbd03fabe08f2b
[packages/perl-libnet.git] / perl-libnet.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    libnet
8 Summary:        Miscellaneous Perl networking modules
9 Summary(cs.UTF-8):      Modul libnet pro Perl
10 Summary(da.UTF-8):      Perl-modulet libnet
11 Summary(de.UTF-8):      libnet Perl Modul
12 Summary(es.UTF-8):      Módulo de Perl libnet
13 Summary(fr.UTF-8):      Module Perl libnet
14 Summary(it.UTF-8):      Modulo di Perl libnet
15 Summary(ja.UTF-8):      libnet Perl モジュール
16 Summary(ko.UTF-8):      libnet 펄 모줄
17 Summary(nb.UTF-8):      Perlmodul libnet
18 Summary(pl.UTF-8):      Różne moduły perlowe do obsługi sieci
19 Summary(pt.UTF-8):      Módulo de Perl libnet
20 Summary(pt_BR.UTF-8):   Módulo Perl libnet
21 Summary(ru.UTF-8):      Модуль для Perl libnet
22 Summary(sv.UTF-8):      libnet Perlmodul
23 Summary(uk.UTF-8):      Модуль для Perl libnet
24 Summary(zh_CN.UTF-8):   libnet Perl 模块
25 Name:           perl-libnet
26 Version:        3.06
27 Release:        1
28 Epoch:          1
29 # same as perl
30 License:        GPL v1+ or Artistic
31 Group:          Development/Languages/Perl
32 Source0:        http://www.cpan.org/modules/by-module/Net/%{pnam}-%{version}.tar.gz
33 # Source0-md5:  fd1f381298d04c1c91f7b2a8a0fb164e
34 Patch0:         %{name}-Configure.patch
35 URL:            http://search.cpan.org/dist/libnet/
36 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.64
37 %if %{with tests}
38 BuildRequires:  perl-Test-Pod >= 1.00
39 BuildRequires:  perl-Test-Pod-Coverage >= 0.08
40 %endif
41 BuildRequires:  perl-devel >= 1:5.8.1
42 BuildRequires:  rpm-perlprov >= 4.1-13
43 Requires:       perl(IO::Socket) >= 1.05
44 # Makefile.PL says so because of some Net::FTP issue (CPAN RT#100020)
45 #Requires:      perl-Socket >= 2.016
46 #Suggests:      perl-IO-Socket-IP >= 0.20 or perl-IO-Socket-INET6 >= 2.62
47 Suggests:       perl-IO-Socket-SSL >= 2.007
48 BuildArch:      noarch
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 # Convert::EBCDIC required only on os390
52 # Authen::SASL and MIME::Base64 required only for SMTP AUTH
53 %define         _noautoreq      'perl(Convert::EBCDIC)' 'perl(Authen::SASL)' 'perl(MIME::Base64)'
54
55 %description
56 libnet is a collection of Perl modules which provides a simple and
57 consistent programming interface (API) to the client side of various
58 protocols used in the internet community. The RFCs implemented in this
59 distribution are:
60
61 - Net::FTP - RFC959 File Transfer Protocol
62 - Net::SMTP - RFC821 Simple Mail Transfer Protocol
63 - Net::Time - RFC867 Daytime Protocol
64 - Net::Time - RFC868 Time Protocol
65 - Net::NNTP - RFC977 Network News Transfer Protocol
66 - Net::POP3 - RFC1939 Post Office Protocol 3
67 - Net::SNPP - RFC1861 Simple Network Pager Protocol
68
69 %description -l pl.UTF-8
70 libnet jest zestawem modułów do Perla, które udostępniają prosty i
71 spójny interfejs programisty (API) do obsługi po stronie klienta
72 różnych protokołów używanych w sieci Internet. Spis dokumentów RFC,
73 które są zaimplementowane w libnet:
74
75 - Net::FTP - RFC959 File Transfer Protocol
76 - Net::SMTP - RFC821 Simple Mail Transfer Protocol
77 - Net::Time - RFC867 Daytime Protocol
78 - Net::Time - RFC868 Time Protocol
79 - Net::NNTP - RFC977 Network News Transfer Protocol
80 - Net::POP3 - RFC1939 Post Office Protocol 3
81 - Net::SNPP - RFC1861 Simple Network Pager Protocol
82
83 %prep
84 %setup -q -n %{pnam}-%{version}
85 %patch0 -p1
86
87 %build
88 %{__perl} Makefile.PL </dev/null \
89         INSTALLDIRS=vendor
90 %{__make}
91
92 %{?with_tests:%{__make} test}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Net/libnetFAQ.pod
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %doc README Changes
108 %config(noreplace) %{perl_vendorlib}/Net/Config.pm
109 %{perl_vendorlib}/Net/Cmd.pm
110 %{perl_vendorlib}/Net/Domain.pm
111 %dir %{perl_vendorlib}/Net/FTP
112 %{perl_vendorlib}/Net/FTP/A.pm
113 %{perl_vendorlib}/Net/FTP/dataconn.pm
114 %{perl_vendorlib}/Net/FTP/E.pm
115 %{perl_vendorlib}/Net/FTP/I.pm
116 %{perl_vendorlib}/Net/FTP/L.pm
117 %{perl_vendorlib}/Net/FTP.pm
118 %{perl_vendorlib}/Net/libnet.cfg
119 %{perl_vendorlib}/Net/NNTP.pm
120 %{perl_vendorlib}/Net/POP3.pm
121 %{perl_vendorlib}/Net/Netrc.pm
122 %{perl_vendorlib}/Net/SMTP.pm
123 %{perl_vendorlib}/Net/Time.pm
124 %{_mandir}/man3/Net::*.3pm*
This page took 0.079509 seconds and 2 git commands to generate.