]> git.pld-linux.org Git - packages/perl-debug.git/blob - perl-debug.spec
be443654aaa432a9f2899ff2f43aa791e9712006
[packages/perl-debug.git] / perl-debug.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    debug
7 Summary:        Perl pragma for debugging and logging of debug lines
8 Summary(pl.UTF-8):      Pakiet Perla do śledzenia i logowania linii diagnostycznych
9 Name:           perl-debug
10 Version:        0.04
11 Release:        1
12 # same as perl
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/S/ST/STEVAN/debug-%{version}.tar.gz
16 # Source0-md5:  b68f551c947039ee6e7f578ba72d8beb
17 URL:            http://search.cpan.org/dist/debug/
18 %if %{with tests}
19 BuildRequires:  perl-Test-Pod >= 1.14
20 BuildRequires:  perl-Test-Pod-Coverage >= 1.04
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The debug pragma provides a very simple way of turning on and off your
27 debugging lines, as well as a very flexible way of logging those lines
28 to literally anywhere you want.
29
30 %description -l pl.UTF-8
31 Pakiet debug udostępnia bardzo prosty sposób włączania i wyłączania
32 linii diagnostycznych, a także bardzo elastyczny sposób logowania tych
33 linii dosłownie wszędzie, gdzie chcemy.
34
35 %prep
36 %setup -q -n %{pdir}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41
42 %{__make}
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/debug.pm
58 %{_mandir}/man3/*
This page took 0.109233 seconds and 2 git commands to generate.