]> git.pld-linux.org Git - packages/perl-debug.git/blob - perl-debug.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-debug.git] / perl-debug.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    debug
6 Summary:        Perl pragma for debugging and logging of debug lines
7 Summary(pl.UTF-8):      Pakiet Perla do śledzenia i logowania linii diagnostycznych
8 Name:           perl-debug
9 Version:        0.04
10 Release:        1
11 # same as perl
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://search.cpan.org/CPAN/authors/id/S/ST/STEVAN/debug-%{version}.tar.gz
15 # Source0-md5:  b68f551c947039ee6e7f578ba72d8beb
16 URL:            http://search.cpan.org/dist/debug/
17 %if %{with tests}
18 BuildRequires:  perl-Test-Pod >= 1.14
19 BuildRequires:  perl-Test-Pod-Coverage >= 1.04
20 %endif
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The debug pragma provides a very simple way of turning on and off your
26 debugging lines, as well as a very flexible way of logging those lines
27 to literally anywhere you want.
28
29 %description -l pl.UTF-8
30 Pakiet debug udostępnia bardzo prosty sposób włączania i wyłączania
31 linii diagnostycznych, a także bardzo elastyczny sposób logowania tych
32 linii dosłownie wszędzie, gdzie chcemy.
33
34 %prep
35 %setup -q -n %{pdir}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40
41 %{__make}
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/debug.pm
57 %{_mandir}/man3/*
This page took 0.060384 seconds and 3 git commands to generate.