]> git.pld-linux.org Git - packages/perl-YAML.git/blob - perl-YAML.spec
dd4c2339e1d2fb4f16014beca8d20a6e94a9f7cf
[packages/perl-YAML.git] / perl-YAML.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    YAML
7 Summary:        YAML - YAML Ain't Markup Language (tm)
8 Summary(pl.UTF-8):      YAML - YAML nie jest językiem znaczników
9 Name:           perl-YAML
10 Version:        1.26
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/YAML/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  e6005ca390f4fcfd714f9e887b9fe204
17 URL:            http://www.yaml.org/spec/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.59
19 BuildRequires:  perl-devel >= 1:5.8.1
20 %if %{with tests}
21 BuildRequires:  perl-Test-Simple >= 0.88
22 BuildRequires:  perl-Test-YAML >= 1.05
23 %endif
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The YAML.pm module implements a YAML Loader and Dumper based on the
30 YAML 1.0 specification.
31
32 YAML is a generic data serialization language that is optimized for
33 human readability. It can be used to express the data structures of
34 most modern programming languages. (Including Perl!!!)
35
36 %description -l pl.UTF-8
37 Moduł YAML.pm jest implementacją klas YAML Loader i Dumper bazujących
38 na specyfikacji YAML 1.0. YAML to język do serializacji ogólnych
39 danych, zoptymalizowany pod względem czytelności dla człowieka. Może
40 być używany do wyrażania struktur danych większości współczesnych
41 języków programowania (włącznie z Perlem).
42
43 %prep
44 %setup -q -n %{pdir}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/YAML.pod
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes
67 %{perl_vendorlib}/YAML.pm
68 %{perl_vendorlib}/YAML
69 %{_mandir}/man3/YAML.3pm*
70 %{_mandir}/man3/YAML::*.3pm*
This page took 0.064289 seconds and 2 git commands to generate.