]> git.pld-linux.org Git - packages/perl-YAML.git/blob - perl-YAML.spec
- tests require perl-perldoc; release 2
[packages/perl-YAML.git] / perl-YAML.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    YAML
7 Summary:        YAML - YAML Ain't Markup Language (tm)
8 Summary(pl):    YAML - YAML nie jest jêzykiem znaczników
9 Name:           perl-YAML
10 Version:        0.38
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/I/IN/INGY/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  13820faf3a87324f46b22908b9f0a755
17 URL:            http://www.yaml.org/spec/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %{?with_tests:BuildRequires:    perl-perldoc}
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The YAML.pm module implements a YAML Loader and Dumper based on the
26 YAML 1.0 specification.
27
28 YAML is a generic data serialization language that is optimized for
29 human readability. It can be used to express the data structures of
30 most modern programming languages.  (Including Perl!!!)
31
32 %description -l pl
33 Modu³ YAML.pm jest implementacj± klas YAML Loader i Dumper bazuj±cych
34 na specyfikacji YAML 1.0. YAML to jêzyk do serializacji ogólnych
35 danych, zoptymalizowany pod wzglêdem czytelno¶ci dla cz³owieka. Mo¿e
36 byæ u¿ywany do wyra¿ania struktur danych wiêkszo¶ci wspó³czesnych
37 jêzyków programowania (w³±cznie z Perlem).
38
39 %prep
40 %setup -q -n %{pdir}-%{version}
41
42 %build
43 yes | perl Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %attr(755,root,root) %{_bindir}/*
61 %{perl_vendorlib}/*.pm
62 %{perl_vendorlib}/%{pdir}
63 %{_mandir}/man[13]/*
This page took 0.026104 seconds and 3 git commands to generate.