]> git.pld-linux.org Git - packages/perl-YAML.git/blob - perl-YAML.spec
- updated to 1.30
[packages/perl-YAML.git] / perl-YAML.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    YAML
6 Summary:        YAML - YAML Ain't Markup Language (tm)
7 Summary(pl.UTF-8):      YAML - YAML nie jest językiem znaczników
8 Name:           perl-YAML
9 Version:        1.30
10 Release:        1
11 # same as perl 5
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/YAML/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  2c861f02e091787c7fe115ec20d3b9b3
16 URL:            https://metacpan.org/release/YAML
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.59
18 BuildRequires:  perl-devel >= 1:5.8.1
19 %if %{with tests}
20 BuildRequires:  perl-Test-Deep
21 BuildRequires:  perl-Test-Simple >= 0.88
22 BuildRequires:  perl-Test-YAML >= 1.05
23 %endif
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  rpmbuild(macros) >= 1.745
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The YAML.pm module implements a YAML Loader and Dumper based on the
31 YAML 1.0 specification.
32
33 YAML is a generic data serialization language that is optimized for
34 human readability. It can be used to express the data structures of
35 most modern programming languages. (Including Perl!!!)
36
37 %description -l pl.UTF-8
38 Moduł YAML.pm jest implementacją klas YAML Loader i Dumper bazujących
39 na specyfikacji YAML 1.0. YAML to język do serializacji ogólnych
40 danych, zoptymalizowany pod względem czytelności dla człowieka. Może
41 być używany do wyrażania struktur danych większości współczesnych
42 języków programowania (włącznie z Perlem).
43
44 %prep
45 %setup -q -n %{pdir}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/YAML.pod
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes
68 %{perl_vendorlib}/YAML.pm
69 %{perl_vendorlib}/YAML
70 %{_mandir}/man3/YAML.3pm*
71 %{_mandir}/man3/YAML::*.3pm*
This page took 0.045694 seconds and 3 git commands to generate.