]> git.pld-linux.org Git - packages/perl-YAML.git/blob - perl-YAML.spec
23f229abaf1f2c026754d2091808e81852a7a074
[packages/perl-YAML.git] / perl-YAML.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    YAML
6 Summary:        YAML - YAML Ain't Markup Language (tm)
7 Summary(pl.UTF-8):      YAML - YAML nie jest językiem znaczników
8 Name:           perl-YAML
9 Version:        1.29
10 Release:        1
11 # same as perl 5
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/YAML/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  3dbb1d9734aef91cec28fb7ccd20cf3a
16 URL:            http://www.yaml.org/spec/
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.59
18 BuildRequires:  perl-devel >= 1:5.8.1
19 %if %{with tests}
20 BuildRequires:  perl-Test-Simple >= 0.88
21 BuildRequires:  perl-Test-YAML >= 1.05
22 %endif
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The YAML.pm module implements a YAML Loader and Dumper based on the
29 YAML 1.0 specification.
30
31 YAML is a generic data serialization language that is optimized for
32 human readability. It can be used to express the data structures of
33 most modern programming languages. (Including Perl!!!)
34
35 %description -l pl.UTF-8
36 Moduł YAML.pm jest implementacją klas YAML Loader i Dumper bazujących
37 na specyfikacji YAML 1.0. YAML to język do serializacji ogólnych
38 danych, zoptymalizowany pod względem czytelności dla człowieka. Może
39 być używany do wyrażania struktur danych większości współczesnych
40 języków programowania (włącznie z Perlem).
41
42 %prep
43 %setup -q -n %{pdir}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/YAML.pod
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes
66 %{perl_vendorlib}/YAML.pm
67 %{perl_vendorlib}/YAML
68 %{_mandir}/man3/YAML.3pm*
69 %{_mandir}/man3/YAML::*.3pm*
This page took 0.048819 seconds and 2 git commands to generate.