]> git.pld-linux.org Git - packages/perl-XML-XSLT-Wrapper.git/blob - perl-XML-XSLT-Wrapper.spec
- fix
[packages/perl-XML-XSLT-Wrapper.git] / perl-XML-XSLT-Wrapper.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    XML
7 %define pnam    XSLT-Wrapper
8 Summary:        XML::XSLT::Wrapper - Consistent interface to XSLT processors
9 Name:           perl-XML-XSLT-Wrapper
10 Version:        0.32
11 Release:        0.2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/M/MU/MULL/XML-XSLT-Wrapper-0.32.tar.gz
16 # Source0-md5:  d08350e5d6a45d5e42ac7ab5fa80fd45
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # found from inline code
23 %define         _noautoreq      'perl(XML::Xalan::Transformer)'
24
25 %description
26 Provides a consistent interface to various XSLT processors.  Tries each
27 of a supplied list of processors in turn until one performs a successful
28 transform. If no list is given, tries all the processors it knows until
29 one works. Does its best to fail gracefully whenever a processor does
30 not work for some reason.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README TODO
57 %dir %{perl_vendorlib}/XML/XSLT
58 %{perl_vendorlib}/XML/XSLT/*.pm
59 %{_mandir}/man3/*
60 %{_examplesdir}/%{name}-%{version}
This page took 0.084272 seconds and 4 git commands to generate.