]> git.pld-linux.org Git - packages/perl-XML-XSH.git/blob - perl-XML-XSH.spec
use generic url
[packages/perl-XML-XSH.git] / perl-XML-XSH.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    XSH
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        XML::XSH - an XML editing shell
9 Summary(pl.UTF-8):      XML::XSH - powłoka do edycji XML-a
10 Name:           perl-XML-XSH
11 Version:        1.8.2
12 Release:        1
13 License:        GPL v2 or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c25f59c465f785347d0466d653d9893f
17 URL:            http://search.cpan.org/dist/XML-XSH/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Parse-RecDescent >= 1.94
22 BuildRequires:  perl-XML-GDOME
23 BuildRequires:  perl-XML-LibXML >= 1.54
24 BuildRequires:  perl-XML-LibXML-XPathContext >= 0.04
25 BuildRequires:  perl-XML-LibXSLT >= 1.53
26 BuildRequires:  perl-XML-XUpdate-LibXML >= 0.4.0
27 %endif
28 Requires:       perl-Parse-RecDescent >= 1.94
29 Requires:       perl-XML-LibXML >= 1.54
30 Requires:       perl-XML-LibXML-XPathContext >= 0.04
31 Requires:       perl-XML-LibXSLT >= 1.53
32 Requires:       perl-XML-XUpdate-LibXML >= 0.4.0
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 xsh is a powerful command-line XML (DOM) editing tool/programming
38 language in the manner of Unix shell interpreters and line-oriented
39 text editors like ed. It can be used either interactively or for
40 batch-mode XML processing.
41
42 %description -l pl.UTF-8
43 xsh to potężne działające z linii poleceń narzędzie do edycji XML-a
44 (DOM), a także język programowania w stylu uniksowych powłok oraz
45 liniowo zorientowanych edytorów w stylu eda. Może być używane
46 interaktywnie lub do wsadowego przetwarzania XML-a.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc BUGS ChangeLog Changes NOTES README TODO
70 %attr(755,root,root) %{_bindir}/xsh
71 %{perl_vendorlib}/XML/XSH.pm
72 %{perl_vendorlib}/XML/XSH
73 %{perl_vendorlib}/Inline/XSH.pm
74 %{_mandir}/man[13]/*
This page took 0.080221 seconds and 3 git commands to generate.