]> git.pld-linux.org Git - packages/perl-XML-XQL.git/blob - perl-XML-XQL.spec
use generic url
[packages/perl-XML-XQL.git] / perl-XML-XQL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    XQL
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        XML::XQL - query XML tree structures with XQL
9 Summary(pl.UTF-8):      XML::XQL - odpytywanie struktur drzewiastych XML-a przy użyciu XQL-a
10 Name:           perl-XML-XQL
11 Version:        0.68
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  bb84096fdf8bcc96a35971539ce8c19e
18 URL:            http://search.cpan.org/dist/XML-XQL/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Date-Manip >= 5.33
23 BuildRequires:  perl-Parse-Yapp
24 BuildRequires:  perl-XML-DOM >= 1.29
25 BuildRequires:  perl-XML-Parser >= 2.30
26 %endif
27 Obsoletes:      perl-libxml-enno
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This is a Perl extension that allows you to perform XQL queries on XML
33 object trees. Currently only the XML::DOM module is supported, but
34 other implementations, like XML::Grove, may soon follow.
35
36 %description -l pl.UTF-8
37 Jest to rozszerzenie Perla pozwalające na wykonywanie zapytań XQL na
38 drzewach obiektów XML. Aktualnie obsługiwany jest tylko moduł
39 XML::DOM, ale może wkrótce będą inne implementacje, takie jak
40 XML::Grove.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48
49 %{__make}
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorlib}/XML/XQL.pm
65 %dir %{perl_vendorlib}/XML/XQL
66 %{perl_vendorlib}/XML/XQL/*.pm
67 %{_mandir}/man3/*
68 %attr(755,root,root) %{_bindir}/*
This page took 0.081723 seconds and 3 git commands to generate.