]> git.pld-linux.org Git - packages/perl-XML-XPath-Simple.git/blob - perl-XML-XPath-Simple.spec
use generic url
[packages/perl-XML-XPath-Simple.git] / perl-XML-XPath-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    XPath-Simple
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        XML::XPath::Simple - very simple interface for XPaths
9 Summary(pl.UTF-8):      XML::XPath::Simple - bardzo prosty interfejs do XPath
10 Name:           perl-XML-XPath-Simple
11 Version:        0.05
12 Release:        2
13 License:        GPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c97b04ecd031e7a27e5b8eb09a44928f
17 URL:            http://search.cpan.org/dist/XML-XPath-Simple/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Simple >= 0.18
22 BuildRequires:  perl-XML-Simple >= 1.08
23 %endif
24 Requires:       perl-XML-Simple >= 1.08
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 XML::XPath::Simple is designed to allow for the use of simple
30 Abbreviated XPath syntax to access values from a small XML document.
31 This module is not meant as a drop-in replacement for XML::XPath, and
32 doesn't support the entire W3C XPath Recommendation. This module is
33 meant as an easy and simple way to access XML data from small,
34 non-complex structures.
35
36 XML::XPath::Simple doesn't support documents that have elements
37 containing mixed content (text and tags), nor does it allow for the
38 walking of the tree structure, or the counting of elements. While this
39 module allows access to specific nodes using the position() function,
40 internally the module doesn't necessarially parse the XML structure in
41 any specific order, so position() calls may not return the value
42 expected.
43
44 %description -l pl.UTF-8
45 XML::XPath::Simple został zaprojektowany aby umożliwić użycie prostej
46 składni Abbreviated XPath do dostępu do wartości z małego dokumentu
47 XML. Ten moduł nie ma być pełnym zamiennikiem XML::XPath i nie
48 obsługuje całej rekomendacji XPath z W3C. Ma być prostym sposobem na
49 dostęp do danych XML z małych, nie złożonych struktur.
50
51 XML::XPath::Simple nie obsługuje dokumentów z elementami o mieszanej
52 treści (tekst i znaczniki), nie pozwala też na przemieszczanie po
53 strukturze drzewa ani liczenie elementów. O ile ten moduł pozwala na
54 dostęp do określonych węzłów przy użyciu funkcji position(),
55 wewnętrznie niekoniecznie analizuje strukturę XML-a w określonej
56 kolejności, więc wywołania position() mogą nie zwrócić takiej
57 wartości, jaką oczekiwano.
58
59 %prep
60 %setup -q -n %{pdir}-%{pnam}-%{version}
61
62 %build
63 %{__perl} Makefile.PL \
64         INSTALLDIRS=vendor
65 %{__make}
66
67 %{?with_tests:%{__make} test}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc Changes README
81 %{perl_vendorlib}/XML/XPath/Simple.pm
82 %{_mandir}/man3/*
This page took 0.110058 seconds and 3 git commands to generate.