]> git.pld-linux.org Git - packages/perl-XML-Twig.git/blob - perl-XML-Twig.spec
4a67c61239403b2db360b86ae17bd28bd85f3a78
[packages/perl-XML-Twig.git] / perl-XML-Twig.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    Twig
8 Summary:        XML::Twig - a perl module for processing huge XML documents in tree mode
9 Summary(pl.UTF-8):      XML::Twig - przetwarzanie dużych dokumentów XML w trybie drzewa
10 Name:           perl-XML-Twig
11 Version:        3.48
12 Release:        1
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1ddcbe84efd3ee2509d72e69fa354b75
17 URL:            http://search.cpan.org/dist/XML-Twig/
18 %if %{with tests}
19 BuildRequires:  perl-Test-Pod
20 BuildRequires:  perl-Text-Iconv
21 BuildRequires:  perl-Tie-IxHash
22 BuildRequires:  perl-Unicode-Map8
23 BuildRequires:  perl-Unicode-String
24 BuildRequires:  perl-XML-Handler-YAWriter
25 BuildRequires:  perl-XML-Parser >= 2.23
26 BuildRequires:  perl-XML-SAX-Writer >= 0.39
27 BuildRequires:  perl-XML-XPath
28 %endif
29 BuildRequires:  perl-devel >= 1:5.8.0
30 BuildRequires:  rpm-perlprov >= 4.1-13
31 Requires:       perl-XML-Parser >= 2.23
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _noautoreq_perl XML::Twig::Elt
36
37 %description
38 This module provides a way to process XML documents. It is build on
39 top of XML::Parser.
40
41 The module offers a tree interface to the document, while allowing you
42 to output the parts of it that have been completely processed.
43
44 %description -l pl.UTF-8
45 Ten moduł udostępnia sposób na przetwarzanie dokumentów XML. Jest
46 zbudowany w oparciu o XML::Parser.
47
48 Moduł oferuje drzewiasty interfejs do dokumentu, pozwalając
49 przekazywać na wyjście części, które zostały już całkowicie
50 przetworzone.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL </dev/null\
57         INSTALLDIRS=vendor
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %attr(755,root,root) %{_bindir}/xml_*
74 %{perl_vendorlib}/XML/Twig.pm
75 %dir %{perl_vendorlib}/XML/Twig
76 %{perl_vendorlib}/XML/Twig/*.pm
77 %{_mandir}/man1/xml_*.1p*
78 %{_mandir}/man3/XML::Twig*.3pm*
This page took 0.047755 seconds and 2 git commands to generate.