]> git.pld-linux.org Git - packages/perl-XML-SAX-Base.git/blob - perl-XML-SAX-Base.spec
- macros for perl autodeps
[packages/perl-XML-SAX-Base.git] / perl-XML-SAX-Base.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    XML
6 %define         pnam    SAX-Base
7 Summary:        XML::SAX::Base - Base class SAX Drivers and Filters
8 Summary(pl.UTF-8):      XML::SAX::Base - klasa bazowa dla sterowników i filtrów SAX
9 Name:           perl-XML-SAX-Base
10 Version:        1.09
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ec347a14065dd7aec7d9fb181b2d7946
17 URL:            https://metacpan.org/release/XML-SAX-Base
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Test-Simple >= 0.88
24 %endif
25 Conflicts:      perl-XML-SAX < 0.99
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 XML::SAX::Base is intended for use as a base class for SAX filter
31 modules and XML parsers generating SAX events.
32
33 %description -l pl.UTF-8
34 Moduł XML::SAX::Base jest przeznaczony do używania jako klasa bazowa
35 dla modułów filtrów SAX oraz analizatorów XML generujących zdarzenia
36 SAX.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %dir %{perl_vendorlib}/XML/SAX
61 %{perl_vendorlib}/XML/SAX/Base.pm
62 %{perl_vendorlib}/XML/SAX/Exception.pm
63 %{perl_vendorlib}/XML/SAX/BuildSAXBase.pl
64 %{_mandir}/man3/XML::SAX::Base.3pm*
65 %{_mandir}/man3/XML::SAX::BuildSAXBase.3pm*
66 %{_mandir}/man3/XML::SAX::Exception.3pm*
This page took 0.07036 seconds and 3 git commands to generate.