]> git.pld-linux.org Git - packages/perl-XML-GDOME.git/blob - perl-XML-GDOME.spec
rebuild with perl 5.32
[packages/perl-XML-GDOME.git] / perl-XML-GDOME.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %define         pdir    XML
6 %define         pnam    GDOME
7 Summary:        XML::GDOME - interface to Level 2 DOM gdome2 library
8 Summary(pl.UTF-8):      XML::GDOME - interfejs do biblioteki DOM Level 2 gdome2
9 Name:           perl-XML-GDOME
10 Version:        0.86
11 Release:        16
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  01ee59f686f9d409bdc316297942ea55
17 URL:            http://search.cpan.org/dist/XML-GDOME/
18 BuildRequires:  gdome2-devel >= 0.7.2
19 BuildRequires:  glib-devel
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-XML-LibXML-Common
24 BuildRequires:  perl-XML-SAX
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 XML::GDOME is a Perl module that provides the DOM Level 2 Core API for
30 accessing XML documents. It uses a XS wrapper around the gdome2
31 library.
32
33 %description -l pl.UTF-8
34 XML::GDOME to moduł Perla dostarczający podstawowe API DOM Level 2 do
35 dostępu do dokumentów XML. Używa wrappera XS do biblioteki gdome2.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorarch}/XML/*.pm
62 %dir %{perl_vendorarch}/XML/GDOME
63 %{perl_vendorarch}/XML/GDOME/SAX
64 %dir %{perl_vendorarch}/auto/XML/GDOME
65 %attr(755,root,root) %{perl_vendorarch}/auto/XML/GDOME/*.so
66 %{_mandir}/man3/*
This page took 0.045252 seconds and 3 git commands to generate.