]> git.pld-linux.org Git - packages/perl-XML-Filter-XSLT.git/blob - perl-XML-Filter-XSLT.spec
use generic url
[packages/perl-XML-Filter-XSLT.git] / perl-XML-Filter-XSLT.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    Filter-XSLT
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        XML::Filter::XSLT - XSLT as a SAX filter
9 Summary(pl.UTF-8):      XML::Filter::XSLT - XSLT jako filtr SAX
10 Name:           perl-XML-Filter-XSLT
11 Version:        0.03
12 Release:        1
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8128f541da6a5a2ee6a3f4764c0652b5
17 URL:            http://search.cpan.org/dist/XML-Filter-XSLT/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-XML-LibXSLT >= 1.31
22 BuildRequires:  perl-XML-SAX >= 0.03
23 BuildRequires:  perl-XML-SAX-Writer >= 0.20
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 It is a simple XSLT SAX2 filter. It uses any available XSLT processor
30 on your system that we can use in some SAXy way. Currently this is
31 just XML::LibXSLT (which we use to build a DOM tree), but we expect
32 more processors will be added over time.
33
34 %description -l pl.UTF-8
35 Jest to prosty filtr XSLT dla SAX2. Korzysta z dowolnego dostępnego w
36 systemie procesora XSLT, z którego potrafi korzystać w jakiś
37 SAX-opodobny sposób. Aktualnie jest to po prostu XML::LibXSLT (używany
38 do tworzenia drzewa DOM), lecz oczekuje się dodania za jakiś czas
39 większej liczby procesorów.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %{perl_vendorlib}/XML/*/*
63 %{_mandir}/man3/*
This page took 0.217525 seconds and 3 git commands to generate.