]> git.pld-linux.org Git - packages/perl-XML-Filter-Namespace.git/blob - perl-XML-Filter-Namespace.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-XML-Filter-Namespace.git] / perl-XML-Filter-Namespace.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    Filter-Namespace
7 Summary:        XML::Filter::Namespace - strip all but a single namespace
8 Summary(pl.UTF-8):      XML::Filter::Namespace - usunięcie wszystkich przestrzeni nazw oprócz jednej
9 Name:           perl-XML-Filter-Namespace
10 Version:        1.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  03ab0c24361eeb965243c8c262cbd7ea
17 URL:            http://search.cpan.org/dist/XML-Filter-Namespace/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Class-Accessor >= 0.17
22 BuildRequires:  perl-Test-Simple
23 BuildRequires:  perl-XML-SAX
24 BuildRequires:  perl-XML-SAX-Writer >= 0.44
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The XML::Filter::Namespace Perl module strips out everything in an XML
31 document that does not belong in a specified namespace. This often
32 provides a view of the XML that is much clearer when multiple
33 namespaces are in use.
34
35 %description -l pl.UTF-8
36 Moduł Perla XML::Filter::Namespace usuwa z dokumentu XML wszystko to,
37 co nie należy do podanej przestrzeni nazw. Zwykle udostępnia to dużo
38 bardziej przejrzysty widok XML-a w przypadku, kiedy użyto wielu
39 przestrzeni nazw.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %attr(755,root,root) %{_bindir}/*
63 %{perl_vendorlib}/XML/*/*.pm
64 %{_mandir}/man3/*
65 %{_mandir}/man1/*
This page took 0.093741 seconds and 3 git commands to generate.