]> git.pld-linux.org Git - packages/perl-XML-Filter-Cache.git/blob - perl-XML-Filter-Cache.spec
use generic url
[packages/perl-XML-Filter-Cache.git] / perl-XML-Filter-Cache.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    Filter-Cache
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        XML::Filter::Cache - a SAX2 recorder/playback mechanism
9 Summary(pl.UTF-8):      XML::Filter::Cache - mechanizm nagrywania/odtwarzania SAX2
10 Name:           perl-XML-Filter-Cache
11 Version:        0.03
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  2590e2a28c5741aa8cd14503e0ea767e
18 Patch0:         %{name}-weird_test_failure.patch
19 URL:            http://search.cpan.org/dist/XML-Filter-Cache/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-XML-SAX >= 0.08
24 BuildRequires:  perl-XML-SAX-Writer >= 0.39
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This is a very simple filter module for SAX2 events. By default it
31 caches events into a big binary file on disk (the cache files are
32 generally much larger than the original XML at the moment, but I'll
33 work on that), but the storage backend is pluggable. It uses Storable
34 to do the freeze/thaw thing, and at the moment this is not pluggin
35 replaceable, simply because there's no better tool for the task at
36 hand.
37
38 %description -l pl.UTF-8
39 To jest bardzo prosty moduł filtra dla zdarzeń SAX2. Domyślnie
40 buforuje on zdarzenia w dużym pliku binarnym na dysku (aktualnie pliki
41 bufora są zwykle o wiele większe niż oryginalny XML, ale autor tym się
42 zajmie), ale backend przechowywania danych jest wymienny. Do
43 wykonywania freeze/thaw używana jest klasa Storable i aktualnie nie
44 jest zamienna, ponieważ po prostu nie ma lepszego narzędzia do tego
45 celu.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49 %patch0 -p0
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %{perl_vendorlib}/XML/*/*
70 %{_mandir}/man3/*
This page took 0.072576 seconds and 3 git commands to generate.