]> git.pld-linux.org Git - packages/perl-XML-DOMHandler.git/blob - perl-XML-DOMHandler.spec
use generic url
[packages/perl-XML-DOMHandler.git] / perl-XML-DOMHandler.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    DOMHandler
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        DOMHandler - implements a call-back interface to DOM
9 Summary(pl.UTF-8):      DOMHandler - implementacja interfejsu callbacków do DOM
10 Name:           perl-XML-DOMHandler
11 Version:        1.0
12 Release:        5
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6dd4dcfed53eb23976c82d097225b430
17 URL:            http://search.cpan.org/dist/XML-DOMHandler/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-XML-LibXML
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module creates a layer on top of DOM that allows you to program
28 in a "push" style rather than "pull". Once the document has been
29 parsed and you have a DOM object, you can call on the DOMHandler's
30 traverse() method to apply a set of call-back routines to all the
31 nodes in a tree. You supply the routines in a handler package when
32 initializing the DOMHandler.
33
34 %description -l pl.UTF-8
35 Ten moduł tworzy warstwę powyżej DOM, pozwalającą na programowaniu w
36 stylu "pchnij" zamiast "ciągnij". Po przeanalizowaniu dokumentu i
37 uzyskaniu obiektu DOM, można wywołać metodę DOMHandlera traverse(),
38 aby zastosować zestaw callbacków na wszystkich węzłach w drzewie.
39 Funkcje przekazuje się przy inicjalizacji DOMHandlera.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %{perl_vendorlib}/%{pdir}/*.pm
63 %{_mandir}/man3/*
This page took 0.23949 seconds and 3 git commands to generate.