]> git.pld-linux.org Git - packages/perl-Wx.git/blob - perl-Wx.spec
- release 3 (by relup.sh)
[packages/perl-Wx.git] / perl-Wx.spec
1
2 # NOTE: On every new version, we need to manually regenerate the list of XS Provides
3 # cd Wx-*
4 # for i in `grep -r "PACKAGE=" * | cut -d " " -f 2 | sed 's|PACKAGE=|perl(|g' | grep "Wx::" | sort -n |uniq`; do printf "Provides: $i)\\n"; done &> provides.txt
5 # grep -orP '%name{Wx::[^}]*}\s+class' |grep -v "3pm" | cut -d : -f 2- | sed 's|%name{|Provides: perl(|g' | sed 's|} class|)|g' |uniq &>> provides.txt
6 # cat provides.txt | uniq | sort -n
7
8 #
9 # Conditional build:
10 %bcond_without  unicode # ANSI instead of Unicode version of wxGTK
11 %bcond_with     gtk3    # wxGTK3 instead of wxGTK2
12 %bcond_with     tests   # "make test" (requires $DISPLAY)
13
14 %define         wxpkg   wxGTK%{?with_gtk3:3}%{!?with_gtk3:2}%{?with_unicode:-unicode}
15 %define         wx_ver          %(rpm -q wxWidgets-devel --qf '%%{VERSION}')
16 %define         wx_ver_tag      %(echo %{wx_ver} | tr . _)
17 %define         alien_wxcfg     gtk%{!?with_gtk3:2}_%{wx_ver_tag}%{?with_unicode:_uni}_gcc_3_4
18 %define         pdir    Wx
19 %include        /usr/lib/rpm/macros.perl
20 Summary:        wxPerl - a Perl wrapper for the wxWidgets C++ GUI toolkit
21 Summary(pl.UTF-8):      wxPerl - wrapper toolkitu graficznego C++ wxWidgets dla Perla
22 Name:           perl-Wx
23 Version:        0.9927
24 Release:        3
25 # same as perl
26 License:        GPL v1+ or Artistic
27 Group:          Development/Languages/Perl
28 Source0:        http://www.cpan.org/modules/by-module/Wx/Wx-%{version}.tar.gz
29 # Source0-md5:  ef05f2f1fc0c3ccb1d4d1aa3896196f9
30 Source1:        perl-provides
31 URL:            http://wxperl.sourceforge.net/
32 BuildRequires:  perl-Alien-wxWidgets >= 0.67
33 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.46
34 BuildRequires:  perl-ExtUtils-ParseXS >= 3.15
35 BuildRequires:  perl-ExtUtils-XSpp >= 0.16_02
36 %if %{with tests}
37 BuildRequires:  perl-Test-Harness >= 2.26
38 BuildRequires:  perl-Test-Simple >= 0.45
39 %endif
40 BuildRequires:  perl-devel >= 1:5.8.0
41 # require Alien::wxWidgets with config for desired wx variant
42 BuildRequires:  %{wxpkg}-devel >= 2.6.3-1
43 BuildRequires:  perl(Alien::wxWidgets::Config::%{alien_wxcfg})
44 BuildRequires:  perl(File::Spec::Functions) >= 0.82
45 BuildRequires:  perl(if) >= 0.03
46 BuildRequires:  rpm-perlprov >= 4.1-13
47 Requires:       perl-Alien-wxWidgets >= 0.25
48 # Load manually generated Perl dependencies, see note on top of spec file
49 %(cat %{SOURCE1})
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 wxPerl is a Perl wrapper for the wxWidgets C++ GUI toolkit.
54
55 %description -l pl.UTF-8
56 wxPerl to wrapper toolkitu graficznego C++ wxWidgets dla Perla.
57
58 %package devel
59 Summary:        Development package for wxPerl
60 Summary(pl.UTF-8):      Pakiet do rozwijania oprogramowania przy użyciu wxPerla
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       %{wxpkg}-devel >= 2.6.3-1
64
65 %description devel
66 Development package for wxPerl.
67
68 %description devel -l pl.UTF-8
69 Pakiet do rozwijania oprogramowania przy użyciu wxPerla.
70
71 %prep
72 %setup -q -n Wx-%{version}
73
74 %build
75 %{__perl} Makefile.PL \
76         INSTALLDIRS=vendor \
77         --wx-toolkit=gtk%{!?with_gtk3:2} \
78         --%{!?with_unicode:no-}wx-unicode
79 %{__make} \
80         CC="%{__cxx}" \
81         OPTIMIZE="%{rpmcflags}"
82
83 %{?with_tests:%{__make} test}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Wx/*.pod
92
93 # not this OS
94 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Wx/build/MakeMaker/{MacOSX,Win32}* \
95         $RPM_BUILD_ROOT%{_mandir}/man3/Wx::build::MakeMaker::Win32_MSVC.3pm
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files
101 %defattr(644,root,root,755)
102 %doc README.txt docs/todo.txt
103 %{perl_vendorarch}/Wx.pm
104 %dir %{perl_vendorarch}/Wx
105 %{perl_vendorarch}/Wx/Perl
106 %{perl_vendorarch}/Wx/*.pm
107 %{perl_vendorarch}/Wx/typemap
108 %dir %{perl_vendorarch}/auto/Wx
109 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/Wx.so
110 %dir %{perl_vendorarch}/auto/Wx/AUI
111 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/AUI/AUI.so
112 %dir %{perl_vendorarch}/auto/Wx/Calendar
113 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/Calendar/Calendar.so
114 %dir %{perl_vendorarch}/auto/Wx/DND
115 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/DND/DND.so
116 %dir %{perl_vendorarch}/auto/Wx/DataView
117 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/DataView/DataView.so
118 %dir %{perl_vendorarch}/auto/Wx/DateTime
119 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/DateTime/DateTime.so
120 %dir %{perl_vendorarch}/auto/Wx/DocView
121 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/DocView/DocView.so
122 %dir %{perl_vendorarch}/auto/Wx/FS
123 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/FS/FS.so
124 %dir %{perl_vendorarch}/auto/Wx/Grid
125 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/Grid/Grid.so
126 %dir %{perl_vendorarch}/auto/Wx/Help
127 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/Help/Help.so
128 %dir %{perl_vendorarch}/auto/Wx/Html
129 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/Html/Html.so
130 %dir %{perl_vendorarch}/auto/Wx/IPC
131 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/IPC/IPC.so
132 %dir %{perl_vendorarch}/auto/Wx/MDI
133 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/MDI/MDI.so
134 %dir %{perl_vendorarch}/auto/Wx/Media
135 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/Media/Media.so
136 %dir %{perl_vendorarch}/auto/Wx/PerlTest
137 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/PerlTest/PerlTest.so
138 %dir %{perl_vendorarch}/auto/Wx/Print
139 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/Print/Print.so
140 %dir %{perl_vendorarch}/auto/Wx/PropertyGrid
141 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/PropertyGrid/PropertyGrid.so
142 %dir %{perl_vendorarch}/auto/Wx/Ribbon
143 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/Ribbon/Ribbon.so
144 %dir %{perl_vendorarch}/auto/Wx/RichText
145 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/RichText/RichText.so
146 %dir %{perl_vendorarch}/auto/Wx/STC
147 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/STC/STC.so
148 %dir %{perl_vendorarch}/auto/Wx/Socket
149 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/Socket/Socket.so
150 %dir %{perl_vendorarch}/auto/Wx/WebView
151 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/WebView/WebView.so
152 %dir %{perl_vendorarch}/auto/Wx/XRC
153 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/XRC/XRC.so
154 %{_mandir}/man3/Wx.3pm*
155 %{_mandir}/man3/Wx::Api.3pm*
156 %{_mandir}/man3/Wx::Loader.3pm*
157 %{_mandir}/man3/Wx::NewClass.3pm*
158 %{_mandir}/man3/Wx::Perl::*.3pm*
159 %{_mandir}/man3/Wx::Socket.3pm*
160 %{_mandir}/man3/Wx::Thread.3pm*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/wxperl_overload
165 %{perl_vendorarch}/Wx/Overload
166 %{perl_vendorarch}/Wx/XSP
167 %{perl_vendorarch}/Wx/build
168 %{perl_vendorarch}/Wx/cpp
169 %{_mandir}/man1/wxperl_overload.1p*
170 %{_mandir}/man3/Wx::XSP::*.3pm*
171 %{_mandir}/man3/Wx::build::*.3pm*
This page took 0.070169 seconds and 3 git commands to generate.