]> git.pld-linux.org Git - packages/perl-WWW-Curl.git/blob - perl-WWW-Curl.spec
c8b4c3fad69613b51e612e73889019b22d9f95f4
[packages/perl-WWW-Curl.git] / perl-WWW-Curl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (fetches URL passed interactively)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    WWW
7 %define         pnam    Curl
8 Summary:        WWW::Curl::easy - Perl extension interface for libcurl
9 Summary(pl.UTF-8):      WWW::Curl::easy - interfejs perlowy do biblioteki libcurl
10 Name:           perl-WWW-Curl
11 Version:        4.15
12 Release:        9
13 License:        MPL or MIT/X
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/S/SZ/SZBALINT/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  31c0b8c7e5e2d26bcc8213d702186d5f
17 URL:            http://curl.haxx.se/libcurl/perl/
18 BuildRequires:  curl-devel
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Obsoletes:      perl-Curl-easy
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 WWW::Curl::easy provides an interface to the libcurl C library
26 <http://curl.haxx.se/>.
27
28 Before v2.0, this module was called 'Curl::easy'. The name has changed
29 to better suit CPAN naming guidelines.
30
31 %description -l pl.UTF-8
32 WWW::Curl::easy dostarcza interfejs do biblioteki C libcurl
33 <http://curl.haxx.se/>.
34
35 Przed wersją 2.0 ten moduł nazywał się Curl::easy. Nazwa została
36 zmieniona, aby lepiej pasowała do wytycznych CPAN dotyczących
37 nazewnictwa.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         LD="%{__cc}" \
48         OPTIMIZE="%{rpmcflags}" \
49         OTHERLDFLAGS="%{rpmldflags}"
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/WWW/Curl/.packlist
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorarch}/WWW/Curl.pm
68 %{perl_vendorarch}/WWW/Curl
69 %dir %{perl_vendorarch}/auto/WWW/Curl
70 %attr(755,root,root) %{perl_vendorarch}/auto/WWW/Curl/Curl.so
71 %{_mandir}/man3/WWW::Curl.3pm*
This page took 0.131838 seconds and 2 git commands to generate.