]> git.pld-linux.org Git - packages/perl-WWW-Curl.git/blob - perl-WWW-Curl.spec
- up to 4.17
[packages/perl-WWW-Curl.git] / perl-WWW-Curl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (fetches URL passed interactively)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    WWW
7 %define         pnam    Curl
8 Summary:        WWW::Curl::easy - Perl extension interface for libcurl
9 Summary(pl.UTF-8):      WWW::Curl::easy - interfejs perlowy do biblioteki libcurl
10 Name:           perl-WWW-Curl
11 Version:        4.17
12 Release:        1
13 License:        MPL or MIT/X
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/S/SZ/SZBALINT/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  997ac81cd6b03b30b36f7cd930474845
17 Patch0:         WWW-Curl-4.17-Skip-preprocessor-symbol-only-CURL_STRICTER.patch
18 URL:            http://curl.haxx.se/libcurl/perl/
19 BuildRequires:  curl-devel
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  perl-Module-Install
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Obsoletes:      perl-Curl-easy
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 WWW::Curl::easy provides an interface to the libcurl C library
28 <http://curl.haxx.se/>.
29
30 Before v2.0, this module was called 'Curl::easy'. The name has changed
31 to better suit CPAN naming guidelines.
32
33 %description -l pl.UTF-8
34 WWW::Curl::easy dostarcza interfejs do biblioteki C libcurl
35 <http://curl.haxx.se/>.
36
37 Przed wersją 2.0 ten moduł nazywał się Curl::easy. Nazwa została
38 zmieniona, aby lepiej pasowała do wytycznych CPAN dotyczących
39 nazewnictwa.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43 %patch0 -p1
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make} \
49         CC="%{__cc}" \
50         LD="%{__cc}" \
51         OPTIMIZE="%{rpmcflags}" \
52         OTHERLDFLAGS="%{rpmldflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} pure_install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/WWW/Curl/.packlist
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorarch}/WWW/Curl.pm
71 %{perl_vendorarch}/WWW/Curl
72 %dir %{perl_vendorarch}/auto/WWW/Curl
73 %attr(755,root,root) %{perl_vendorarch}/auto/WWW/Curl/Curl.so
74 %{_mandir}/man3/WWW::Curl.3pm*
This page took 0.064964 seconds and 3 git commands to generate.