]> git.pld-linux.org Git - packages/perl-WWW-Curl.git/blob - perl-WWW-Curl.spec
- fix building with curl 7.69.x
[packages/perl-WWW-Curl.git] / perl-WWW-Curl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (fetches URL passed interactively)
4 #
5 %define         pdir    WWW
6 %define         pnam    Curl
7 Summary:        WWW::Curl::easy - Perl extension interface for libcurl
8 Summary(pl.UTF-8):      WWW::Curl::easy - interfejs perlowy do biblioteki libcurl
9 Name:           perl-WWW-Curl
10 Version:        4.17
11 Release:        5
12 License:        MPL or MIT/X
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/S/SZ/SZBALINT/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  997ac81cd6b03b30b36f7cd930474845
16 Patch0:         WWW-Curl-4.17-Skip-preprocessor-symbol-only-CURL_STRICTER.patch
17 Patch1:         curl-7.66.0.patch
18 Patch2:         curl-7.69.0.patch
19 URL:            http://curl.haxx.se/libcurl/perl/
20 BuildRequires:  curl-devel
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  perl-Module-Install
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Obsoletes:      perl-Curl-easy
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 WWW::Curl::easy provides an interface to the libcurl C library
29 <http://curl.haxx.se/>.
30
31 Before v2.0, this module was called 'Curl::easy'. The name has changed
32 to better suit CPAN naming guidelines.
33
34 %description -l pl.UTF-8
35 WWW::Curl::easy dostarcza interfejs do biblioteki C libcurl
36 <http://curl.haxx.se/>.
37
38 Przed wersją 2.0 ten moduł nazywał się Curl::easy. Nazwa została
39 zmieniona, aby lepiej pasowała do wytycznych CPAN dotyczących
40 nazewnictwa.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44 %patch0 -p1
45 %patch1 -p1
46 %patch2 -p1
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make} \
52         CC="%{__cc}" \
53         LD="%{__cc}" \
54         OPTIMIZE="%{rpmcflags}" \
55         OTHERLDFLAGS="%{rpmldflags}"
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/WWW/Curl/.packlist
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README
73 %{perl_vendorarch}/WWW/Curl.pm
74 %{perl_vendorarch}/WWW/Curl
75 %dir %{perl_vendorarch}/auto/WWW/Curl
76 %attr(755,root,root) %{perl_vendorarch}/auto/WWW/Curl/Curl.so
77 %{_mandir}/man3/WWW::Curl.3pm*
This page took 0.095171 seconds and 3 git commands to generate.