]> git.pld-linux.org Git - packages/perl-WWW-Chat.git/blob - perl-WWW-Chat.spec
use generic url
[packages/perl-WWW-Chat.git] / perl-WWW-Chat.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    WWW
6 %define         pnam    webchat
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        WWW::Chat Perl modules - processing web chat scripts
9 Summary(pl.UTF-8):      Moduły Perla WWW::Chat - przetwarzanie skryptów chata
10 Name:           perl-WWW-Chat
11 Version:        0.64
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  1b8ebf6aa942dfd1c79ce6dff7bae134
18 URL:            http://search.cpan.org/dist/webchat/
19 BuildRequires:  perl-Data-Dump >= 0.01
20 BuildRequires:  perl-HTML-Parser >= 2.21
21 BuildRequires:  perl-URI >= 1.00
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  perl-libwww >= 5.47
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This package contains the 'webchatpp' program, with its support
30 modules WWW::Chat and WWW::Chat::Processor.
31
32 The 'webchatpp' program is a preprocessor that turns chat scripts into
33 plain perl scripts using libwww-perl. When the script created by
34 webchatpp is feed to perl it will perform the chatting. Chat scripts
35 are useful for setting up test suites for web applications or just to
36 automate dialogues with web applications.
37
38 %description -l pl.UTF-8
39 Ten pakiet zawiera program webchatpp wraz z modułami pomocniczymi
40 WWW::Chat i WWW::Chat::Processor.
41
42 webchatpp jest preprocesorem tłumaczącym skrypty chata na zwykłe
43 skrypty Perla używające modułów libwww. Utworzony skrypt jest
44 przekazywany do Perla, który przeprowadza dialog. Skrypty chata są
45 przydatne do tworzenia testów aplikacji WWW lub automatyzacji dialogów
46 z aplikacjami WWW.
47
48 %prep
49 %setup -q -n %{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README manual_test.pl
70 %attr(755,root,root) %{_bindir}/*
71 %{perl_vendorlib}/WWW/Chat.pm
72 %{perl_vendorlib}/WWW/Chat
73 %{_mandir}/man[13]/*
This page took 0.064116 seconds and 3 git commands to generate.