]> git.pld-linux.org Git - packages/perl-VCS.git/blob - perl-VCS.spec
use generic url
[packages/perl-VCS.git] / perl-VCS.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (needs working, not busy /dev/audio!)
4
5 %define         pdir    VCS
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        VCS - library for generic Version Control System access in Perl
8 Summary(pl.UTF-8):      VCS - biblioteka umożliwiająca dostęp do systemu kontroli wersji (VCS) z poziomu Perla
9 Name:           perl-VCS
10 Version:        0.16
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/VCS/VCS-%{version}.tar.gz
16 # Source0-md5:  5e3965ef83514629fe2fbc6da3f1eb66
17 URL:            http://search.cpan.org/dist/VCS/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 3.0.3-16
20 %if %{with tests}
21 BuildRequires:  perl-Sort-Versions
22 BuildRequires:  rcs
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 VCS is an API for abstracting access to all version control systems
29 from Perl code. This is achieved in a similar fashion to the DBI suite
30 of modules. There are "container" classes, VCS::Dir, VCS::File, and
31 VCS::Version, and "implementation" classes, such as VCS::Cvs::Dir,
32 VCS::Cvs::File, and VCS::Cvs::Version, which are subclasses of their
33 respective "container" classes.
34
35 %description -l pl.UTF-8
36 VCS stanowi API dla abstrakcyjnego dostępu z kodu w Perlu do wszelkich
37 systemów kontroli wersji. Osiąga się to w podobny sposób, jak w
38 zestawie modułów DBI. Istnieją klasy "pojemników": VCS::Dir, VCS::File
39 i VCS::Version oraz klasy "implementacji", takie jak: VCS::Cvs::Dir,
40 VCS::Cvs::File i VCS::Cvs::Version, będące podklasami swoich
41 odpowiednich klas "pojemników".
42
43 %prep
44 %setup -q -n VCS-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %attr(755,root,root) %{_bindir}/diff-hist
68 %{perl_vendorlib}/VCS.pm
69 %{perl_vendorlib}/VCS
70 %{_mandir}/man[13]/*
71 %{_examplesdir}/%{name}-%{version}
This page took 0.460661 seconds and 3 git commands to generate.