]> git.pld-linux.org Git - packages/perl-VCP.git/blob - perl-VCP.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-VCP.git] / perl-VCP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do perform "make test"
4 #                         [why it was disabled instead of fixing?]
5 #
6 %define         pnam    VCP
7 Summary:        Data::VCP - Versioned Copy, copying hierarchies of versioned files
8 Summary(pl.UTF-8):      Data::VCP - wersjonowane kopie - kopiowanie hierarchii wersjonowanych plików
9 Name:           perl-VCP
10 %define _snap   20050110
11 %define _ver    0.9
12 Version:        %{_ver}_%{_snap}
13 Release:        4
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/authors/id/A/AU/AUTRIJUS/VCP-autrijus-snapshot-%{_ver}-%{_snap}.tar.gz
18 # Source0-md5:  c01249d810904f5b4f6080979673a514
19 URL:            http://search.cpan.org/~autrijus/VCP-autrijus-snapshot/
20 BuildRequires:  perl-BFD
21 BuildRequires:  perl-IPC-Run3
22 BuildRequires:  perl-PodToHTML
23 BuildRequires:  perl-Regexp-Shellish >= 0.93
24 BuildRequires:  perl-Text-Diff
25 BuildRequires:  perl-Text-Table
26 BuildRequires:  perl-XML-AutoWriter
27 BuildRequires:  perl-devel >= 1:5.8.0
28 BuildRequires:  rpm-perlprov >= 4.1-13
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _noautoreq      'perl(mkss)' 'perl(VCP::.*)' 'perl(RevML::.*)'
33
34 %description
35 Versioned Copy, copying hierarchies of versioned files.
36
37 %description -l pl.UTF-8
38 Wersjonowane kopie - kopiowanie hierarchii wersjonowanych plików.
39
40 %prep
41 %setup -q -n VCP-autrijus-snapshot-%{_ver}-%{_snap}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make} -j1
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGE*
62 %attr(755,root,root) %{_bindir}/*
63 %{perl_vendorlib}/RevML
64 %{perl_vendorlib}/VCP
65 %{perl_vendorlib}/VCP.pm
66 %{_mandir}/man[13]/*
This page took 0.130405 seconds and 3 git commands to generate.