]> git.pld-linux.org Git - packages/perl-Unix-Processors.git/blob - perl-Unix-Processors.spec
11f5ac66b84fe769151fd5a7be70b613136c2300
[packages/perl-Unix-Processors.git] / perl-Unix-Processors.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Unix
7 %define         pnam    Processors
8 Summary:        Unix::Processors - interface to processor (CPU) information
9 Summary(pl.UTF-8):      Unix::Processors - interfejs do informacji o procesorze (CPU)
10 Name:           perl-Unix-Processors
11 Version:        2.042
12 Release:        5
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Unix/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  641db045b253a1b75a1dcbc615981b40
17 URL:            http://search.cpan.org/dist/Unix-Processors/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 Requires:       perl-dirs >= 1.0-7
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This package provides accessors to per-processor (CPU) information.
25 The object is obtained with the Unix::Processors::processors call in a
26 OS independent manner.
27
28 %description -l pl.UTF-8
29 Ten pakiet udostępnia funkcje dostępowe do informacji o procesorach
30 (CPU). Ten obiekt jest dostępny poprzez wywołanie
31 Unix::Processors::processors w sposób niezależny od systemu
32 operacyjnego.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %{perl_vendorarch}/Unix/*.pm
58 %{perl_vendorarch}/Unix/Processors
59 %dir %{perl_vendorarch}/auto/Unix/Processors
60 %attr(755,root,root) %{perl_vendorarch}/auto/Unix/Processors/*.so
61 %{_mandir}/man3/*
This page took 0.073446 seconds and 2 git commands to generate.