]> git.pld-linux.org Git - packages/perl-Unicode-Map8.git/blob - perl-Unicode-Map8.spec
05adf9542d9e1e56f1cb46d5948c4bc2d83c6d6b
[packages/perl-Unicode-Map8.git] / perl-Unicode-Map8.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Unicode
6 %define         pnam    Map8
7 Summary:        Unicode::Map8 - mapping table between 8-bit chars and Unicode
8 Summary(pl.UTF-8):      Unicode::Map8 - tabela odwzorowująca między znakami 8-bitowymi a Unikodem
9 Name:           perl-Unicode-Map8
10 Version:        0.13
11 Release:        14
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Unicode/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  fc93a37cabcae488bd95ca07bf5c919e
17 Patch0:         %{name}-types.patch
18 URL:            http://search.cpan.org/dist/Unicode-Map8/
19 BuildRequires:  perl-Unicode-String >= 2.00
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The Unicode::Map8 class implement efficient mapping tables between
26 8-bit character sets and 16 bit character sets like Unicode. The
27 tables are efficient both in terms of space allocated and translation
28 speed. The 16-bit strings is assumed to use network byte order.
29
30 %description -l pl.UTF-8
31 Klasa Unicode::Map8 implementuje wydajne tablice odwzorowujące
32 pomiędzy 8-bitowymi zestawami znaków a 16-bitowymi zestawami takimi
33 jak Unikod. Tablice są wydajne zarówno jeśli chodzi o ilość
34 przydzielonego miejsca, jak i szybkość konwersji. Zakłada się, że
35 łańcuchy 16-bitowe używają sieciowej kolejności bajtów w słowie.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39 %patch0 -p1
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56 install {diff_iso,make*maps,map8_*} \
57         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README rfc1345.txt
65 %attr(755,root,root) %{_bindir}/umap
66 %{perl_vendorarch}/Unicode/Map8.pm
67 %{perl_vendorarch}/Unicode/Map8
68 %dir %{perl_vendorarch}/auto/Unicode/Map8
69 %attr(755,root,root) %{perl_vendorarch}/auto/Unicode/Map8/Map8.so
70 %{_mandir}/man1/umap.1p*
71 %{_mandir}/man3/Unicode::Map8.3pm*
72 %dir %{_examplesdir}/%{name}-%{version}
73 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.060233 seconds and 2 git commands to generate.