]> git.pld-linux.org Git - packages/perl-Unicode-LineBreak.git/blob - perl-Unicode-LineBreak.spec
b21869489aed6020088e43352446d63dffb10b60
[packages/perl-Unicode-LineBreak.git] / perl-Unicode-LineBreak.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Unicode
6 %define         pnam    LineBreak
7 Summary:        Unicode::LineBreak - UAX #14 Unicode Line Breaking Algorithm
8 Summary(pl.UTF-8):      Unicode::LineBreak - algorytm łamiania linii w Unikodzie UAX #14
9 Name:           perl-Unicode-LineBreak
10 Version:        2018.003
11 Release:        4
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Unicode/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  736dcb04f6a250bd28e4279f2b8592af
17 URL:            http://search.cpan.org/dist/Unicode-LineBreak/
18 BuildRequires:  libthai-devel >= 0.1.9
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  sombok-devel >= 2.4.0
23 BuildRequires:  sombok-devel < 3
24 %if %{with tests}
25 BuildRequires:  perl-Encode >= 1:1.98
26 BuildRequires:  perl-MIME-Charset >= 1.006.2
27 %endif
28 Requires:       sombok >= 2.4.0
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Unicode::LineBreak performs Line Breaking Algorithm described in
33 Unicode Standard Annex #14 [UAX #14]. East_Asian_Width informative
34 property defined by Annex #11 [UAX #11] will be concerned to determine
35 breaking positions.
36
37 %description -l pl.UTF-8
38 Unicode::LineBreak wykonuje algorytm łamania linii opisany w
39 dokumencie Unicode Standard Annex #14 (UAX #14). Przy określaniu
40 miejsc łamania brana jest pod uwagę własność informacyjna
41 East_Asian_Width zdefiniowana w dokumencie Annex #11 (UAX #11).
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make} \
50         CC="%{__cc}" \
51         OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Unicode/*.pod
62 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/POD2/JA/Text/*.pod
63 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/POD2/JA/Unicode/*.pod
64
65 install -d $RPM_BUILD_ROOT%{_mandir}/ja/man3
66 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man3/POD2::JA::Text::LineFold.3pm $RPM_BUILD_ROOT%{_mandir}/ja/man3/Text::LineFold.3pm
67 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man3/POD2::JA::Unicode::GCString.3pm $RPM_BUILD_ROOT%{_mandir}/ja/man3/Unicode::GCString.3pm
68 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man3/POD2::JA::Unicode::LineBreak.3pm $RPM_BUILD_ROOT%{_mandir}/ja/man3/Unicode::LineBreak.3pm
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 %dir %{perl_vendorarch}/auto/Unicode/LineBreak
77 %attr(755,root,root) %{perl_vendorarch}/auto/Unicode/LineBreak/LineBreak.so
78 %{perl_vendorarch}/Text/LineFold.pm
79 %{perl_vendorarch}/Unicode/GCString.pm
80 %{perl_vendorarch}/Unicode/LineBreak.pm
81 %dir %{perl_vendorarch}/Unicode/LineBreak
82 %{perl_vendorarch}/Unicode/LineBreak/Constants.pm
83 %{_mandir}/man3/Text::LineFold.3pm*
84 %{_mandir}/man3/Unicode::GCString.3pm*
85 %{_mandir}/man3/Unicode::LineBreak.3pm*
86 %lang(ja) %{_mandir}/ja/man3/Text::LineFold.3pm*
87 %lang(ja) %{_mandir}/ja/man3/Unicode::GCString.3pm*
88 %lang(ja) %{_mandir}/ja/man3/Unicode::LineBreak.3pm*
This page took 0.041042 seconds and 2 git commands to generate.