]> git.pld-linux.org Git - packages/perl-Unicode-LineBreak.git/blob - perl-Unicode-LineBreak.spec
- new
[packages/perl-Unicode-LineBreak.git] / perl-Unicode-LineBreak.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Unicode
6 %define         pnam    LineBreak
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Unicode::LineBreak - UAX #14 Unicode Line Breaking Algorithm
9 Name:           perl-Unicode-LineBreak
10 Version:        2017.004
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Unicode/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  de7672227922260ac92d20bbad29660b
17 URL:            http://search.cpan.org/dist/Unicode-LineBreak/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-MIME-Charset
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Unicode::LineBreak performs Line Breaking Algorithm described in
27 Unicode Standard Annex #14 [UAX #14]. East_Asian_Width informative
28 property defined by Annex #11 [UAX #11] will be concerned to determine
29 breaking positions.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make} \
38         CC="%{__cc}" \
39         OPTIMIZE="%{rpmcflags}"
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} pure_install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %dir %{perl_vendorarch}/auto/Unicode/LineBreak
56 %attr(755,root,root) %{perl_vendorarch}/auto/Unicode/LineBreak/*.so
57 %dir %{perl_vendorarch}/POD2
58 %dir %{perl_vendorarch}/POD2/JA
59 %dir %{perl_vendorarch}/POD2/JA/Text
60 %{perl_vendorarch}/POD2/JA/Text/LineFold.pod
61 %dir %{perl_vendorarch}/POD2/JA/Unicode
62 %{perl_vendorarch}/POD2/JA/Unicode/GCString.pod
63 %{perl_vendorarch}/POD2/JA/Unicode/LineBreak.pod
64 %{perl_vendorarch}/Text/LineFold.pm
65 %{perl_vendorarch}/Unicode/*.pm
66 %{perl_vendorarch}/Unicode/GCString.pod
67 %{perl_vendorarch}/Unicode/LineBreak.pod
68 %dir %{perl_vendorarch}/Unicode/LineBreak
69 %{perl_vendorarch}/Unicode/LineBreak/Constants.pm
70 %{_mandir}/man3/*
This page took 0.06318 seconds and 3 git commands to generate.