]> git.pld-linux.org Git - packages/perl-UUID-Tiny.git/blob - perl-UUID-Tiny.spec
- new
[packages/perl-UUID-Tiny.git] / perl-UUID-Tiny.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    UUID
6 %define         pnam    Tiny
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        UUID::Tiny - Pure Perl UUID Support With Functional Interface
9 Summary(pl.UTF-8):      UUID::Tiny - czysto perlowa obsługa UUID-ów z interfejsem funkcyjnym
10 Name:           perl-UUID-Tiny
11 Version:        1.04
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/UUID/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  2d7c18711e64e0a64cc7c7fbb870947e
18 URL:            http://search.cpan.org/dist/UUID-Tiny/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Digest-MD5
23 BuildRequires:  perl-MIME-Base64
24 BuildRequires:  perl-Test-Simple
25 BuildRequires:  perl-Time-HiRes
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 UUID::Tiny is a lightweight, low dependency Pure Perl module for UUID
32 creation and testing. This module provides the creation of version 1
33 time based UUIDs (using random multicast MAC addresses), version 3 MD5
34 based UUIDs, version 4 random UUIDs, and version 5 SHA-1 based UUIDs.
35
36 %description -l pl.UTF-8
37 UUID::Tiny to lekki, mający mało zależności, napisany w czystym Perlu
38 moduł do tworzenia i testowania UUID-ów. Udostępnia tworzenie UUID-ów
39 w wersji 1 opartych na czasie (wykorzystujących losowe adresy
40 multicastowe MAC), UUID-ów w wersji 3 opartych na MD5, UUID-ów
41 losowych w wersji 4 oraz UUID-ów w wersji 5 opartych na SHA-1.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorlib}/UUID/Tiny.pm
66 %{_mandir}/man3/UUID::Tiny.3pm*
This page took 0.050063 seconds and 3 git commands to generate.