]> git.pld-linux.org Git - packages/perl-URI.git/blob - perl-URI.spec
- added URL
[packages/perl-URI.git] / perl-URI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    URI
7 %define         pnam    URI
8 Summary:        URI - Uniform Resource Identifiers (absolute and relative)
9 Summary(pl):    URI - obs³uga ujednoliconych identyfikatorów zasobów (bezwzglêdnych i wzglêdnych)
10 Summary(ru):    URI - Uniform Resource Identifier (URI) ÓÓÙÌËÉ, ËÁË ÕËÁÚÙ×ÁÅÔ RFC 2396
11 Summary(uk):    URI - ÐÏÓÉÌÁÎÎÑ Uniform Resource Identifier (URI) ÑË ×ÉÚÎÁÞÅÎÏ × RFC 2396
12 Name:           perl-URI
13 Version:        1.35
14 Release:        2
15 # same as perl
16 License:        GPL v1+ or Artistic
17 Group:          Development/Languages/Perl
18 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
19 # Source0-md5:  1a933b1114c41a25587ee59ba8376f7c
20 URL:            http://search.cpan.org/dist/URI/
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-MIME-Base64
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreq      'perl(Business::ISBN)'
30
31 %description
32 This package contains the URI.pm module with friends. The module
33 implements the URI class. Objects of this class represent Uniform
34 Resource Identifier (URI) references as specified in RFC 2396.
35
36 %description -l ru
37 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ URI.pm É ÓÏÐÕÔÓÔ×ÕÀÝÉÅ ÍÏÄÕÌÉ. íÏÄÕÌØ ÒÅÁÌÉÚÕÅÔ
38 Uniform Resource Identifier (URI) ÓÓÙÌËÉ, ËÁË ÕËÁÚÙ×ÁÅÔ RFC 2396.
39
40 %description -l pl
41 Ten pakiet zawiera modu³ URI dla Perla. S³u¿y on do obróbki
42 ujednoliconych identyfikatorów zasobów (URI - Uniform Resource
43 Identifier), zgodnych z RFC 2396.
44
45 %description -l pt_BR
46 Módulo Perl URI - Este pacote contém o modulo URI.pm para manipular
47 "Uniform Resource Identifier" (URI) confirme especificado na RFC 2396.
48
49 %description -l uk
50 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ URI.pm ÔÁ ÐÏÔÒ¦ÂΦ ÄÌÑ ÎØÏÇÏ ÍÏÄÕ̦. íÏÄÕÌØ ÒÅÁ̦ÚÕ¤
51 ÐÏÓÉÌÁÎÎÑ Uniform Resource Identifier (URI) ÑË ÚÁÚÎÁÞÅÎÏ × RFC 2396.
52
53 %prep
54 %setup -q -n %{pnam}-%{version}
55 mv t/heuristic.t{,.blah}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc README Changes
76 %{perl_vendorlib}/URI
77 %{perl_vendorlib}/*.pm
78 %{_mandir}/man3/*
This page took 0.076493 seconds and 3 git commands to generate.