]> git.pld-linux.org Git - packages/perl-Tree-RedBlack.git/blob - perl-Tree-RedBlack.spec
use generic url
[packages/perl-Tree-RedBlack.git] / perl-Tree-RedBlack.spec
1 %define         pdir    Tree
2 %define         pnam    RedBlack
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        Tree::RedBlack - Perl implementation of Red/Black tree, a type of balanced tree
5 Summary(pl.UTF-8):      Tree::RedBlack - implementacja perlowa drzew czerwono-czarnych
6 Name:           perl-Tree-RedBlack
7 Version:        0.5
8 Release:        1
9 License:        Artistic
10 Group:          Development/Languages/Perl
11 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
12 # Source0-md5:  46a749fa2aa047d5a044ecf0a0fbc925
13 URL:            http://search.cpan.org/dist/Tree-RedBlack/
14 BuildRequires:  perl-devel >= 1:5.8.0
15 BuildRequires:  rpm-perlprov >= 4.1-13
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This is a Perl implementation of the Red/Black tree algorithm found in
21 the book "Algorithms", by Cormen, Leiserson & Rivest (more commonly
22 known as "CLR" or "The White Book"). A Red/Black tree is a binary tree
23 which remains "balanced" - that is, the longest length from root to a
24 node is at most one more than the shortest such length. It is fairly
25 efficient; no operation takes more than O(lg(n)) time.
26
27 %description -l pl.UTF-8
28 To jest perlowa implementacja algorytmu drzew czerwono-czarnych, którą
29 można znaleźć w książce "Algorithms" autorstwa Cormena, Leisersona i
30 Rivesta (częściej znanej jako "CLR" lub "Biała księga"). Drzewo
31 czerwono-czarne to binarne drzewo, które pozostaje wyważone - czyli
32 najdłuższa droga od korzenia do liścia jest najwyżej o jeden dłuższa
33 od najkrótszej. Jest dość wydajne; żadna operacja nie trwa dłużej niż
34 O(log(n)).
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/Tree/RedBlack.pm
57 %{perl_vendorlib}/Tree/RedBlack
58 %{_mandir}/man3/*
This page took 0.281733 seconds and 3 git commands to generate.