]> git.pld-linux.org Git - packages/perl-Tree-MultiNode.git/blob - perl-Tree-MultiNode.spec
use generic url
[packages/perl-Tree-MultiNode.git] / perl-Tree-MultiNode.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Tree
6 %define         pnam    MultiNode
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Tree::MultiNode Perl module - a multi node tree object
9 Summary(pl.UTF-8):      Moduł Perla Tree::MultiNode - obiekt drzewa wielowęzłowego
10 Name:           perl-Tree-MultiNode
11 Version:        1.0.10
12 Release:        2
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  5616a11ec829742fc53d34e46782ae5a
17 URL:            http://search.cpan.org/dist/Tree-MultiNode/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Tree::MultiNode, Tree::MultiNode::Node, and Tree::MultiNode::Handle
25 are objects modeled after C++ classes that I had written to help me
26 model hierarchical information as datastructures (such as the
27 relationships between records in an RDBMS). The tree is basically a
28 list of lists type data structure, where each node has a key, a value,
29 and a list of children. The tree has no internal sorting, though all
30 operations perserve the order of the child nodes.
31
32 %description -l pl.UTF-8
33 Tree::MultiNode, Tree::MultiNode::Node i Tree::MultiNode::Handle to
34 obiekty stworzone na podstawie klas C++ napisanych dla ułatwienia
35 opracowania modelu hierarchicznej informacji jako struktur danych
36 (takich jak relacje pomiędzy rekordami w relacyjnej bazie danych).
37 Drzewo jest zasadniczo strukturą danych typu lista list, gdzie każdy
38 węzeł ma klucz, wartość i listę potomków. Drzewo nie ma wewnętrznego
39 sortowania, ale wszystkie operacje zachowują kolejność węzłów
40 potomnych.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README test.pl
64 %{perl_vendorlib}/Tree/MultiNode.pm
65 %{_mandir}/man3/*
This page took 0.056977 seconds and 3 git commands to generate.