]> git.pld-linux.org Git - packages/perl-Tie-TwoLevelHash.git/blob - perl-Tie-TwoLevelHash.spec
use generic url
[packages/perl-Tie-TwoLevelHash.git] / perl-Tie-TwoLevelHash.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Tie
6 %define         pnam    TwoLevelHash
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Tie::TwoLevelHash - tied interface to multi-dimensional (two-level) hash files
9 Summary(pl.UTF-8):      Tie::TwoLevelHash - interfejs do wielowymiarowych (dwupoziomowych) plików haszy
10 Name:           perl-Tie-TwoLevelHash
11 Version:        1.2
12 Release:        12
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  68cb91a69c63ef90018e7395948fa828
18 URL:            http://search.cpan.org/dist/Tie-TwoLevelHash/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This is the Tie::TwoLevelHash module. It is a TIEHASH interface which
26 lets you tie to a text file which is a multi-dimensional (two level)
27 hash.
28
29 %description -l pl.UTF-8
30 To jest moduł Tie::TwoLevelHash. Jest to interfejs TIEHASH, który
31 pozwala dowiązać się do pliku tekstowego, który jest wielowymiarowym
32 (dwupoziomowym) haszem.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README
56 %{perl_vendorlib}/Tie/TwoLevelHash.pm
57 %{_mandir}/man3/*
This page took 1.781792 seconds and 3 git commands to generate.