]> git.pld-linux.org Git - packages/perl-Tie-TransactHash.git/blob - perl-Tie-TransactHash.spec
use generic url
[packages/perl-Tie-TransactHash.git] / perl-Tie-TransactHash.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Tie
6 %define         pnam    TransactHash
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Tie::TransactHash - edit hash in transactions not changing order during trans
9 Summary(pl.UTF-8):      Tie::TransactHash - edycja hasza w transakcjach nie zmieniających kolejności
10 Name:           perl-Tie-TransactHash
11 Version:        0.03
12 Release:        12
13 # README claims "same as perl" and GPL v2+
14 License:        GPL v2+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  0a25fc726b2f45cfaa6780b2cf3ccf0f
18 URL:            http://search.cpan.org/dist/Tie-TransactHash/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Getopt-Mixed
23 BuildRequires:  perl-Tie-IxHash
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Tie::TransactHash is a package which provides facilities for editing
30 any other hash in transactions. A transaction is a group of changes
31 which go together and are either all applied or none. When working on
32 a standard perl hash or a hash indexed DBM file, one advantage is that
33 the original hash remains untouched during the transaction, so its
34 order (the order the each(), keys() or values() functions give out) is
35 maintained - changes can be made to the transact hash whilst iterating
36 over it.
37
38 %description -l pl.UTF-8
39 Tie::TransactHash to pakiet udostępniający możliwość modyfikowania
40 innych haszy w transakcjach. Transakcja to grupa zmian, które albo są
41 wykonywanie wszystkie, albo żadna. Przy pracy z normalnymi haszami
42 perlowymi lub plikiem DBM poindeksowanym haszem, zaletą jest to, że
43 oryginalny hasz pozostaje nietknięty podczas transakcji, więc jego
44 kolejność (kolejność, w jakiej zwracają wartości funkcje each(),
45 keys() i values()) jest zachowana - zmainy mogą być robione w
46 transakcji podczas iteracji po haszu.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README TODO
70 %attr(755,root,root) %{_bindir}/edit-db.pl
71 %{perl_vendorlib}/Tie/TransactHash.pm
72 %{_mandir}/man[13]/*
This page took 0.081914 seconds and 3 git commands to generate.