]> git.pld-linux.org Git - packages/perl-Tie-Scalar-Timeout.git/blob - perl-Tie-Scalar-Timeout.spec
use generic url
[packages/perl-Tie-Scalar-Timeout.git] / perl-Tie-Scalar-Timeout.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Tie
6 %define         pnam    Scalar-Timeout
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Tie::Scalar::Timeout - scalar variables that time out
9 Summary(pl.UTF-8):      Tie::Scalar::Timeout - zmienne skalarne ulegające przedawnieniu
10 Name:           perl-Tie-Scalar-Timeout
11 Version:        2.101420
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  7466a9d2e052556140003b49b612cef1
18 URL:            http://search.cpan.org/dist/Tie-Scalar-Timeout/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module allows you to tie a scalar variable whose value will be
26 reset (subject to an expiry policy) after a certain time and/or a
27 certain number of uses. One possible application for this module might
28 be to time out session variables in mod_perl programs.
29
30 %description -l pl.UTF-8
31 Ten moduł pozwala wiązanie zmiennej skalarnej, której wartość będzie
32 przywrócona (zgodnie z polisą przedawnienia) po danym czasie i/lub
33 liczbie odwołań. Jednym z zastosowań tego modułu może być
34 przedawnianie zmiennych sesji w programach mod_perla.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %dir %{perl_vendorlib}/Tie/Scalar
58 %{perl_vendorlib}/Tie/Scalar/*.pm
59 %{_mandir}/man3/*
This page took 0.062957 seconds and 3 git commands to generate.