]> git.pld-linux.org Git - packages/perl-Tie-STDERR.git/blob - perl-Tie-STDERR.spec
use generic url
[packages/perl-Tie-STDERR.git] / perl-Tie-STDERR.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Tie
6 %define         pnam    STDERR
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Tie::STDERR - send output of your STDERR to a process or mail
9 Summary(pl.UTF-8):      Tie::STDERR - wysyłanie standardowego wyjścia błędu do procesu lub pocztą
10 Name:           perl-Tie-STDERR
11 Version:        0.122
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  65bdd4f54c4e6a06cd7444e885c05f22
18 URL:            http://search.cpan.org/dist/Tie-STDERR/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Sends all output that would otherwise go to STDERR either by email to
26 root or whoever is responsible, or to a file or a process, or calls
27 your function at the end of the script. This way you can easily change
28 the destination of your error messages from inside of your script. The
29 mail will be sent or the system command or Perl function run only if
30 there actually is some output detected - something like cron would do.
31
32 %description -l pl.UTF-8
33 Ten moduł przesyła całe wyjście, jakie zwykle poszłoby na standardowe
34 wyjście błędu (STDERR) pocztą do administratora albo do pliku lub
35 procesu, albo wywołuje funkcję na końcu skryptu. Ten sposób pozwala
36 łatwo zmienić przeznaczenie komunikatów błędów z wnętrza skryptu.
37 Poczta może być wysłana poleceniem systemowym lub funkcją Perla
38 uruchomioną tylko w przypadku, kiedy coś się pojawi na wyjściu -
39 podobnie, jak robi to cron.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/Tie/STDERR.pm
64 %{_mandir}/man3/*
This page took 0.059971 seconds and 3 git commands to generate.