]> git.pld-linux.org Git - packages/perl-Text-Trac.git/blob - perl-Text-Trac.spec
use generic url
[packages/perl-Text-Trac.git] / perl-Text-Trac.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Text
6 %define         pnam    Trac
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Text::Trac - extension for formatting text with Trac Wiki Style
9 Name:           perl-Text-Trac
10 Version:        0.15
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  57757c5e9c742232b811af33b224357a
17 URL:            http://search.cpan.org/dist/Text-Trac/
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-Test-Base
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Text::Trac parses text with Trac WikiFormatting and convert it to html
27 format.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make}
36
37 %{?with_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README
51 %{perl_vendorlib}/Text/Trac.pm
52 %{perl_vendorlib}/Text/Trac
53 %{_mandir}/man3/*
This page took 0.08781 seconds and 3 git commands to generate.