]> git.pld-linux.org Git - packages/perl-Text-BibTeX.git/blob - perl-Text-BibTeX.spec
- rebuild with perl 5.30.0
[packages/perl-Text-BibTeX.git] / perl-Text-BibTeX.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 #
5 %define         pdir    Text
6 %define         pnam    BibTeX
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Text::BibTeX - Perl library for reading, parsing and processing BibTeX files
9 Summary(pl.UTF-8):      Text::BibTeX - biblioteka Perla do odczytu, analizy i przetwarzania plików BibTeXa
10 Name:           perl-Text-BibTeX
11 Version:        0.88
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Text/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  361aad5cf400764e35d1ade3b609bb60
18 Patch0:         %{name}-mansect.patch
19 Patch1:         %{name}-libdir.patch
20 URL:            http://www.gerg.ca/software/btOOL/
21 BuildRequires:  perl-Capture-Tiny >= 0.06
22 BuildRequires:  perl-Config-AutoConf >= 0.16
23 BuildRequires:  perl-ExtUtils-CBuilder >= 0.27
24 BuildRequires:  perl-ExtUtils-LibBuilder >= 0.02
25 BuildRequires:  perl-Module-Build >= 0.3603
26 BuildRequires:  perl-devel >= 1:5.8.0
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 %if %{with tests}
29 BuildRequires:  perl-Scalar-List-Utils >= 1.42
30 BuildRequires:  perl-Unicode-Normalize
31 %endif
32 Requires:       btparse = %{version}-%{release}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Text::BibTeX is a Perl library for reading, parsing, and processing
37 BibTeX files. It is the Perl half of btOOL, a pair of libraries for
38 dealing with BibTeX data.
39
40 %description -l pl.UTF-8
41 Text::BibTeX to biblioteka Perla do odczytu, analizy i przetwarzania
42 plików BibTeXa. Jest to perlowa połowa projektu btOOL - pary bibliotek
43 do obsługi danych BibTeXa.
44
45 %package -n btparse
46 Summary:        C library to parse BibTeX files
47 Summary(pl.UTF-8):      Biblioteka C do analizy plików BibTeXa
48 Group:          Libraries
49
50 %description -n btparse
51 btparse is the C component of btOOL, a pair of libraries for parsing
52 and processing BibTeX files. Its primary use is as the back-end to
53 Text::BibTeX library for Perl (the other half of btOOL), but there's
54 nothing to prevent you from writing C programs using btparse - or from
55 writing extensions to other high-level languages using btparse as a
56 back-end.
57
58 %description -n btparse -l pl.UTF-8
59 btparse to część C narzędzia btOOL - pary bibliotek do analizy i
60 przetwarzania plików BibTeX. Głównym zastosowaniem jest backend dla
61 biblioteki Text::BibTeX dla Perla (drugiej połówki narzędzia btOOL),
62 ale nic nie stoi na przeszkodzie pisaniu programów w C
63 wykorzystujących btparse albo rozszerzeń dla innych wysokopoziomowych
64 języków z wykorzystaniem btparse jako backendu.
65
66 %package -n btparse-devel
67 Summary:        Header files for btparse library
68 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki btparse
69 Group:          Development/Libraries
70 Requires:       btparse = %{version}-%{release}
71 Obsoletes:      btparse-static < %{version}
72
73 %description -n btparse-devel
74 Header files for btparse library.
75
76 %description -n btparse-devel -l pl.UTF-8
77 Pliki nagłówkowe biblioteki btparse.
78
79 %prep
80 %setup -q -n %{pdir}-%{pnam}-%{version}
81 %patch0 -p1
82 %patch1 -p1
83
84 %build
85 LIBDIR=%{_libdir} \
86 %{__perl} Build.PL \
87         --config cc="%{__cc}" \
88         --config optimize="%{rpmcflags}" \
89         installdirs=vendor
90 ./Build
91
92 %{?with_tests:./Build test}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 ./Build install \
98         destdir=$RPM_BUILD_ROOT
99
100 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Text/BibTeX/BibTeX.bs
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -n btparse -p /sbin/ldconfig
106 %postun -n btparse -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc Changes README
111 %{perl_vendorarch}/Text/BibTeX.pm
112 %{perl_vendorarch}/Text/BibTeX
113 %dir %{perl_vendorarch}/auto/Text/BibTeX
114 %attr(755,root,root) %{perl_vendorarch}/auto/Text/BibTeX/BibTeX.so
115 %{_mandir}/man3/Text::BibTeX.3pm*
116 %{_mandir}/man3/Text::BibTeX::*.3pm*
117
118 %files -n btparse
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/biblex
121 %attr(755,root,root) %{_bindir}/bibparse
122 %attr(755,root,root) %{_bindir}/dumpnames
123 %attr(755,root,root) %{_libdir}/libbtparse.so
124
125 %files -n btparse-devel
126 %defattr(644,root,root,755)
127 %{_includedir}/btparse.h
128 %{_mandir}/man3/bt_*.3*
129 %{_mandir}/man3/btparse.3*
130 %{_mandir}/man3/btool_faq.3*
This page took 0.071015 seconds and 3 git commands to generate.