]> git.pld-linux.org Git - packages/perl-Test-utf8.git/blob - perl-Test-utf8.spec
d5ce5fcd24438ade054906a286318249f6c4b4c6
[packages/perl-Test-utf8.git] / perl-Test-utf8.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    utf8
7 Summary:        Test::utf8 - handy UTF-8 tests
8 Summary(pl.UTF-8):      Test::utf8 - podręczne testy UTF-8
9 Name:           perl-Test-utf8
10 Version:        1.01
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  58351d9e168399f6e55fb0982cdbe6a1
17 URL:            https://metacpan.org/release/Test-utf8
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Builder-Tester >= 0.09
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module is a collection of tests useful for dealing with UTF-8
28 strings in Perl.
29
30 This module has two types of tests: The validity tests check if a
31 string is valid and not corrupt, whereas the characteristics tests
32 will check that string has a given set of characteristics.
33
34 %description -l pl.UTF-8
35 Ten moduł to zbiór testów przydatnych przy obsłudze łańcuchów
36 znaków UTF-8 w Perlu.
37
38 Moduł ma dwa rodzaje testów: testy poprawności, sprawdzające, czy
39 łańcuch jest poprawny oraz testy charakterystyki, sprawdzające, czy
40 łancuch ma dany zbiór cech.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc CHANGES
64 %{perl_vendorlib}/Test/utf8.pm
65 %{_mandir}/man3/Test::utf8.3pm*
This page took 0.102879 seconds and 2 git commands to generate.