]> git.pld-linux.org Git - packages/perl-Test-UseAllModules.git/blob - perl-Test-UseAllModules.spec
use generic url
[packages/perl-Test-UseAllModules.git] / perl-Test-UseAllModules.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Test
6 %define pnam    UseAllModules
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Test::UseAllModules - do use_ok() for all the MANIFESTed modules
9 Summary(pl.UTF-8):      Test::UseAllModules - wykonaj use_ok() dla wszystkich modułów MANIFEST
10 Name:           perl-Test-UseAllModules
11 Version:        0.13
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b591f8f8de76dd36422a60e2d02fcbdd
18 URL:            http://search.cpan.org/dist/Test-UseAllModules/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 I'm sick of writing 00_load.t (or something like that) that'll do
26 use_ok() for every module I write. I'm sicker of updating 00_load.t
27 when I add another file to the distro. This module reads MANIFEST to
28 find modules to be tested and does use_ok() for each of them. Now all
29 you have to do is update MANIFEST. You don't have to modify the test
30 any more (hopefully).
31
32 %description -l pl.UTF-8
33 Test::UseAllModules - wykonaj use_ok() dla wszystkich modułów MANIFEST
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/Test/*.pm
58 %{_mandir}/man3/*
This page took 0.082185 seconds and 3 git commands to generate.