]> git.pld-linux.org Git - packages/perl-Test-Taint.git/blob - perl-Test-Taint.spec
6ef75e26a2912bfaf31da6a8e1eb26f0eabb424e
[packages/perl-Test-Taint.git] / perl-Test-Taint.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Test
6 %define         pnam    Taint
7 Summary:        Test::Taint - tools to test taintedness
8 Summary(pl.UTF-8):      Test::Taint - narzędzia do sprawdzania napiętnowania
9 Name:           perl-Test-Taint
10 Version:        1.08
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d59152acb169a34640bec861fca170de
17 URL:            https://metacpan.org/release/Test-Taint
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Tainted data is data that comes from an unsafe source, such as the
25 command line, or, in the case of web apps, any GET or POST
26 transactions (see perlsec(1) man page for details on why tainted data
27 is bad, and how to untaint the data).
28
29 When you're writing unit tests for code that deals with tainted data,
30 you'll want to have a way to provide tainted data for your routines to
31 handle, and easy ways to check and report on the taintedness of your
32 data, in standard Test::More style.
33
34 %description -l pl.UTF-8
35 Dane napiętnowane to dane pochodzące z niebezpiecznego źródła, takiego
36 jak linia poleceń, lub, w przypadku aplikacji WWW, wszelkie transakcje
37 GET i POST (na stronie podręcznika perlsec(1) można znaleźć
38 dokładniejsze informacje dlaczego dane napiętnowane są złe i jak
39 pozbyć się z nich piętna).
40
41 Przy pisaniu testów jednostkowych dla kodu przetwarzającego dane
42 napiętnowane zwykle chcemy móc dostarczyć napiętnowane dane do
43 własnych funkcji i w łatwy sposób sprawdzić napiętnowanie naszych
44 danych w standardowym stylu Test::More.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make} \
53         CC="%{__cc}" \
54         OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes
70 %{perl_vendorarch}/Test/Taint.pm
71 %dir %{perl_vendorarch}/auto/Test/Taint
72 %attr(755,root,root) %{perl_vendorarch}/auto/Test/Taint/Taint.so
73 %{_mandir}/man3/Test::Taint.3pm*
This page took 0.046478 seconds and 2 git commands to generate.