]> git.pld-linux.org Git - packages/perl-Test-TCP.git/blob - perl-Test-TCP.spec
use generic url
[packages/perl-Test-TCP.git] / perl-Test-TCP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Test
6 %define         pnam    TCP
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Test::TCP - testing TCP program
9 Name:           perl-Test-TCP
10 Version:        1.15
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  34a449920cff4a591d4a65a28b354d0a
17 URL:            http://search.cpan.org/dist/Test-TCP/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Test::SharedFork) >= 0.14
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Test::TCP is test utilities for TCP/IP programs.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make}
36
37 %{?with_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} pure_install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc Changes README
51 %{perl_vendorlib}/Test/*.pm
52 %{_mandir}/man3/*
This page took 0.055303 seconds and 3 git commands to generate.