]> git.pld-linux.org Git - packages/perl-Test-TCP.git/blob - perl-Test-TCP.spec
- up to 2.22
[packages/perl-Test-TCP.git] / perl-Test-TCP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Test
6 %define         pnam    TCP
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Test::TCP - testing TCP program
9 Summary(pl.UTF-8):      Test::TCP - testowanie programów TCP
10 Name:           perl-Test-TCP
11 Version:        2.22
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  d539ad6b16856e863a6b6b54fa58df33
18 URL:            http://search.cpan.org/dist/Test-TCP/
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-SharedFork >= 0.29
23 BuildRequires:  perl-Test-Simple >= 0.98
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Test::TCP is test utilities for TCP/IP programs.
30
31 %description -l pl.UTF-8
32 Test::TCP to narzędzia testowe dla programów TCP/IP.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README.md
56 %{perl_vendorlib}/Net/EmptyPort.pm
57 %{perl_vendorlib}/Test/TCP.pm
58 %{perl_vendorlib}/Test/TCP
59 %{_mandir}/man3/Net::EmptyPort.3pm*
60 %{_mandir}/man3/Test::TCP.3pm*
61 %{_mandir}/man3/Test::TCP::CheckPort.3pm*
This page took 0.091906 seconds and 3 git commands to generate.