]> git.pld-linux.org Git - packages/perl-Test-Script.git/blob - perl-Test-Script.spec
3a14924e16890c067724b17cab9dbd2bbe9f507a
[packages/perl-Test-Script.git] / perl-Test-Script.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Script
8 Summary:        Test::Script - Cross-platform basic tests for scripts
9 Summary(pl.UTF-8):      Test::Script - wieloplatformowe podstawowe testy dla skryptów
10 Name:           perl-Test-Script
11 Version:        1.07
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/ADAMK/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f6b5baa6403cd24dac7f023e0ea22384
18 URL:            http://search.cpan.org/dist/Test-Script/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-IPC-Run3 >= 0.034
23 BuildRequires:  perl-Probe-Perl >= 0.01
24 BuildRequires:  perl-Test-Builder-Tester >= 1.02
25 BuildRequires:  perl-Test-Simple >= 0.62
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The intent of this module is to provide a series of basic tests for
32 scripts in the bin directory of your Perl distribution. Further, it
33 aims to provide them with perfect platform-compatibility and in a way
34 that is as unobtrusive as possible. That is, if the program works on a
35 platform, then Test::Script should also work on that platform. In
36 doing so, it is hoped that Test::Script can become a module that you
37 can safely make a dependency of your module, without risking your
38 module not working on some platform because of the dependency. Where a
39 clash exists between wanting more functionality and maintaining
40 platform safety, this module will err on the side of platform safety.
41
42 %description -l pl.UTF-8
43 Przeznaczeniem tego modułu jest zapewnienie serii podstawowych testów
44 dla skryptów z katalogu bin pakietu perlowego. Ponadto ma na celu
45 udostępnienie im doskonałej kompatybilności z platformami w możliwie
46 niekłopotliwy sposób. Oznacza to, że jeśli program działa na jakiejś
47 platformie, Test::Script także powinien na tej platformie działać.
48 Przy tym Test::Script powinien stać się modułem, który bezpiecznie
49 można uczynić zależnością własnego modułu bez ryzykowania, że moduł
50 przestanie działać na jakiejś platformie z powodu tej zależności. Tam,
51 gdzie występuje kolizja między większą funkcjonalnością a zachowaniem
52 zgodności z platformą, ten moduł stanie po stronie zgodności.
53
54 %prep
55 %setup -q -n %{pdir}-%{pnam}-%{version}
56
57 %build
58 %{__perl} Makefile.PL \
59         INSTALLDIRS=vendor
60 %{__make}
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes
76 %{perl_vendorlib}/Test/Script.pm
77 %{_mandir}/man3/Test::Script.3pm*
This page took 0.083018 seconds and 2 git commands to generate.