]> git.pld-linux.org Git - packages/perl-Test-Most.git/blob - perl-Test-Most.spec
- new
[packages/perl-Test-Most.git] / perl-Test-Most.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Most
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Test::Most - Most commonly needed test functions and features
9 Summary(pl.UTF-8):      Test::Most - najczęściej potrzebne funkcje testowe
10 Name:           perl-Test-Most
11 Version:        0.35
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  03dbabd34d6f40af8bd47f5fbb0c6989
18 URL:            http://search.cpan.org/dist/Test-Most/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Exception-Class >= 1.14
23 BuildRequires:  perl-Test-Deep >= 0.119
24 BuildRequires:  perl-Test-Differences >= 0.64
25 BuildRequires:  perl-Test-Exception >= 0.43
26 BuildRequires:  perl-Test-Harness >= 3.35
27 BuildRequires:  perl-Test-Simple >= 1.302047
28 BuildRequires:  perl-Test-Warn >= 0.30
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Test::Most exists to reduce boilerplate and to make your testing life
35 easier. We provide "one stop shopping" for most commonly used testing
36 modules. In fact, we often require the latest versions so that you get
37 bug fixes through Test::Most and don't have to keep upgrading these
38 modules separately.
39
40 This module provides you with the most commonly used testing
41 functions, along with automatically turning on strict and warning and
42 gives you a bit more fine-grained control over your test suite.
43
44 %description -l pl.UTF-8
45 Celem Test::Most jest zmniejszenie ilości ramowego kodu i ułatwienie
46 testowania. Moduł pozwala na jednoczesne włączenie najczęściej
47 używanych modułów testowych; zwykle wymagane są najnowsze wersje, aby
48 zapewnić poprawienie znanych błędów bez potrzeby uaktualniania modułów
49 osobno.
50
51 Test::Most dostarcza najczęściej używane funkcje testujące,
52 jednocześnie włączając tryb ścisły (strict) i ostrzeżenia, a także
53 pozwalając na elastyczną kontrolę zestawu testów.
54
55 %prep
56 %setup -q -n %{pdir}-%{pnam}-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make}
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} pure_install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc Changes README
77 %{perl_vendorlib}/Test/Most.pm
78 %{perl_vendorlib}/Test/Most
79 %{_mandir}/man3/Test::Most.3pm*
80 %{_mandir}/man3/Test::Most::Exception.3pm*
This page took 0.08888 seconds and 3 git commands to generate.