]> git.pld-linux.org Git - packages/perl-Test-MockTime.git/blob - perl-Test-MockTime.spec
0bdd7a6255b63afb80c2be2573b96ccec027c271
[packages/perl-Test-MockTime.git] / perl-Test-MockTime.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Test
7 %define pnam    MockTime
8 Summary:        Test::MockTime - Replaces actual time with simulated time
9 #Summary(pl.UTF-8):     
10 Name:           perl-Test-MockTime
11 Version:        0.12
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  de726192bcdd0cef68a07ffdf11d7300
18 URL:            http://search.cpan.org/dist/Test-MockTime/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module was created to enable test suites to test code at specific 
26 points in time. Specifically it overrides localtime, gmtime and time at
27 compile time and then relies on the user supplying a mock time via 
28 set_relative_time, set_absolute_time or set_fixed_time to alter future 
29 calls to gmtime,time or localtime.
30
31 # %description -l pl.UTF-8
32 # TODO
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes
56 %{perl_vendorlib}/Test/*.pm
57 %{_mandir}/man3/*
This page took 0.026578 seconds and 2 git commands to generate.